码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2387-Til the Cows Come Home(最短路Dijkstra+优先队列)

时间:2014-08-17 15:35:32      阅读:226      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   os   io   strong   for   ar   

Til the Cows Come Home
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 30007   Accepted: 10092

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John‘s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90
赤裸裸的Dijkstra 刚开始学最短路,先噜一发最简单的,刚学会用优先队列,所以用优先队列写的Dijkstra,对这个大材小用了,这个直接邻接矩阵就可以过(邻接矩阵注意重边取小)
#include <cstdio>
#include <iostream>
#include <cstring>
#include <cctype>
#include <cstdlib>
#include <algorithm>
#include <vector>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <list>
using namespace std;
const  int maxn=500010;
const int INF=1<<29;
typedef struct node{
	int p,w;
	node(int a,int b){p=a;w=b;}
	friend bool operator<(node a,node b){//权值小的先出队
	    if(a.w!=b.w) return a.w<b.w;
	    return a.p<b.p;
	}

};
vector <node> eg[maxn];//vector存图
int dis[maxn],n;
void Dijkstra(int src)
{
	for(int i=0;i<=n;i++) dis[i]=INF;//初始化
	dis[src]=0;
	priority_queue <node> Q;
	Q.push(node(src,dis[src]));//源点入队
	while(!Q.empty()){
		node f=Q.top();Q.pop();
		for(int i=0;i<eg[f.p].size();i++){
			node t=eg[f.p][i];
			if(dis[t.p]>t.w+f.w){ //三角形原则更新距离
				dis[t.p]=t.w+f.w;
				Q.push(node(t.p,dis[t.p]));
			}
		}
	}

}
int main()
{
	int u,v,m,w;
	while(scanf("%d%d",&m,&n)!=EOF){
		for(int i=0;i<=n;i++) eg[i].clear();
		while(m--){

			scanf("%d%d%d",&u,&v,&w);

			eg[u].push_back(node(v,w));
			eg[v].push_back(node(u,w));
		}
		Dijkstra(1);
		printf("%d\n",dis[n]);
	}
	return 0;
}


POJ 2387-Til the Cows Come Home(最短路Dijkstra+优先队列),布布扣,bubuko.com

POJ 2387-Til the Cows Come Home(最短路Dijkstra+优先队列)

标签:des   style   color   os   io   strong   for   ar   

原文地址:http://blog.csdn.net/qq_16255321/article/details/38639243

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!