码迷,mamicode.com
首页 > 其他好文 > 详细

codevs1842 递归第一次

时间:2016-12-11 10:15:20      阅读:123      评论:0      收藏:0      [点我收藏+]

标签:default   sample   hint   表示   using   cout   style   put   script   

难度等级:白银

1842 递归第一次

题目描述 Description

同学们在做题时常遇到这种函数

f(x)=5 (x>=0)

f(x)=f(x+1)+f(x+2)+1 (x<0)

下面就以这个函数为题做一个递归程序吧

输入描述 Input Description

一个数表示f(x)中x值

大家注意就一个数,前面代表样例编号

输出描述 Output Description

一个数表示值

大家注意就一个数,前面代表样例编号

样例输入 Sample Input

样例一:0

样例二:-5

样例输出 Sample Output

样例一:5

样例二:77

数据范围及提示 Data Size & Hint

x>=-30

#include<iostream>
using namespace std;
int f(int x)
{
    if(x>=0) return 5;
    return f(x+1)+f(x+2)+1;
}
int main()
{
    int x;
    cin>>x;
    cout<<f(x);
}

 

codevs1842 递归第一次

标签:default   sample   hint   表示   using   cout   style   put   script   

原文地址:http://www.cnblogs.com/TheRoadToTheGold/p/6159012.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!