码迷,mamicode.com
首页 > 其他好文 > 详细

UVA - 10497 Sweet Child Makes Trouble

时间:2014-08-17 20:00:42      阅读:291      评论:0      收藏:0      [点我收藏+]

标签:java   os   for   ar   问题   amp   line   new   

Children are always sweet but they can sometimesmake you feel bitter. In this problem, you will see how Tintin, a five year’sold boy, creates trouble for his parents. Tintin is a joyful boy and is alwaysbusy in doing something. But what he does is not always pleasant for hisparents. He likes most to play with household things like his father’swristwatch or his mother’s comb. After his playing he places it in some otherplace. Tintin is very intelligent and a boy with a very sharp memory. To makethings worse for his parents, he never returns the things he has taken forplaying to their original places.

Think about a morning when Tintin has managed to‘steal’ three household objects. Now, in how many ways he can place thosethings such that nothing is placed in their original place. Tintin does notlike to give his parents that much trouble. So, he does not leave anything in acompletely new place; he merely permutes the objects.

Input

There will be several test cases. Each will havea positive integer less than or equal to 800 indicating the number of thingsTintin has taken for playing. Each integer will be in a line by itself. The inputis terminated by a –1 (minus one) in a single line, which should not beprocessed.

Output

For each test case print an integer indicating inhow many ways Tintin can rearrange the things he has taken.

Sample Input

2
3
4
-1

SampleOutput

1
2
9
题意:放回不同位置的方案数
思路:简单的错排问题,高精度处理
import java.math.BigInteger;
import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		final int maxn = 805;
		BigInteger f[] = new BigInteger[maxn];
		f[1] = BigInteger.ZERO;
		f[2] = BigInteger.ONE;
		for (int i = 3; i < maxn; i++)
			f[i] = (f[i-2].add(f[i-1])).multiply(BigInteger.valueOf(i-1));

		Scanner in = new Scanner(System.in);
		int n;
		while (true) {
			n = in.nextInt();
			if (n == -1)
				break;
			System.out.println(f[n]);
		}
	}
}


UVA - 10497 Sweet Child Makes Trouble,布布扣,bubuko.com

UVA - 10497 Sweet Child Makes Trouble

标签:java   os   for   ar   问题   amp   line   new   

原文地址:http://blog.csdn.net/u011345136/article/details/38641233

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!