码迷,mamicode.com
首页 > 其他好文 > 详细

Einbahnstrasse

时间:2016-12-16 22:50:21      阅读:207      评论:0      收藏:0      [点我收藏+]

标签:键值   ace   where   lin   har   gem   mem   std   travel   

Einbahnstrasse

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 124 Accepted Submission(s): 54
 
Problem Description
Einbahnstra 技术分享 e (German for a one-way street) is a street on which vehicles should only move in one direction. One reason for having one-way streets is to facilitate a smoother flow of traffic through crowded areas. This is useful in city centers, especially old cities like Cairo and Damascus. Careful planning guarantees that you can get to any location starting from any point. Nevertheless, drivers must carefully plan their route in order to avoid prolonging their trip due to one-way streets. Experienced drivers know that there are multiple paths to travel between any two locations. Not only that, there might be multiple roads between the same two locations. Knowing the shortest way between any two locations is a must! This is even more important when driving vehicles that are hard to maneuver (garbage trucks, towing trucks, etc.)

You just started a new job at a car-towing company. The company has a number of towing trucks parked at the company‘s garage. A tow-truck lifts the front or back wheels of a broken car in order to pull it straight back to the company‘s garage. You receive calls from various parts of the city about broken cars that need to be towed. The cars have to be towed in the same order as you receive the calls. Your job is to advise the tow-truck drivers regarding the shortest way in order to collect all broken cars back in to the company‘s garage. At the end of the day, you have to report to the management the total distance traveled by the trucks.
 
Input
Your program will be tested on one or more test cases. The first line of each test case specifies three numbers (N , C , and R ) separated by one or more spaces. The city has N locations with distinct names, including the company‘s garage. C is the number of broken cars. R is the number of roads in the city. Note that 0 < N < 100 , 0<=C < 1000 , and R < 10000 . The second line is made of C + 1 words, the first being the location of the company‘s garage, and the rest being the locations of the broken cars. A location is a word made of 10 letters or less. Letter case is significant. After the second line, there will be exactly R lines, each describing a road. A road is described using one of these three formats:


A -v -> B
A <-v - B
A <-v -> B


A and B are names of two different locations, while v is a positive integer (not exceeding 1000) denoting the length of the road. The first format specifies a one-way street from location A to B , the second specifies a one-way street from B to A , while the last specifies a two-way street between them. A , ``the arrow", and B are separated by one or more spaces. The end of the test cases is specified with a line having three zeros (for N , C , and R .)

The test case in the example below is the same as the one in the figure.

技术分享
 
Output
For each test case, print the total distance traveled using the following format:


k . V


Where k is test case number (starting at 1,) is a space, and V is the result.
 
Sample Input
4 2 5
NewTroy Midvale Metrodale
NewTroy   <-20-> Midvale
Midvale   --50-> Bakerline
NewTroy    <-5-- Bakerline
Metrodale <-30-> NewTroy
Metrodale  --5-> Bakerline
0 0 0
 
Sample Output
1. 80
 
 
Source
2008 ANARC
 
Recommend
lcy
 
/*
求从总公司出发按顺序访问各个点然后回到公司的最小距离

Floyd 是固定松弛点在放缩,想错了
floy算法最简便
*/
#include<bits/stdc++.h>
#define N 105
#define INF 0x3f3f3f3f
#define ll long long
using namespace std;
int n,c,m,cur;
int mapn[N][N];
map<string,int>ma;
char city[1005][N],u[N],v[N],opl,opr;
int val;
/*
void floyd(){
    for(int i=1;i<=n;i++){
        for(int j=1;j<=n;j++){
            for(int k=1;k<=n;k++){
                mapn[i][j]=min(mapn[i][j],mapn[i][k]+mapn[k][j]);
            }
        }
    }
}
*/
/*
手写模板错了,应该固定松弛的点然后,在更新状态
*/
void floyd()
{
    int i,j,k;
    for(i = 1; i<=n; i++)
        for(j = 1; j<=n; j++)
            for(k = 1; k<=n; k++)
                if(mapn[j][i]+mapn[i][k]<mapn[j][k])
                    mapn[j][k] = mapn[j][i]+mapn[i][k];
}

void init(){
    for(int i=0;i<=n;i++){
        for(int j=0;j<=n;j++){
            mapn[i][j]=INF;
        }
    }
}
int main(){
    //freopen("C:\\Users\\acer\\Desktop\\in.txt","r",stdin);
    int Case=1;
    while(scanf("%d%d%d",&n,&c,&m)!=EOF&&(n+c+m)){
        init();
        ma.clear();
        for(int i=0;i<=c;i++){
            scanf("%s",city[i]);
            //cout<<city<<" ";
        }
        //cout<<endl;
        int len=1;//表示结点(这个地方坐标必须从1开始,因为map中没有的东西会返回的键值是0)
        for(int i=0;i<m;i++){
            scanf("%s %c-%d-%c %s",u,&opl,&val,&opr,v);
            //printf("%s %c-%d-%c %s\n",u,opl,val,opr,v);
            /*
            利用map的性质,没有插入的元素的第二个键值为0
            */
            if(!ma[u]){//在城市中没有标记
                ma[u]=len++;
                //cout<<u<<endl;
            }
            if(!ma[v]){//在城市中没有标记
                ma[v]=len++;
                //cout<<v<<endl;
            }
            if(opl==<){
                if(mapn[ma[v]][ma[u]]>val)
                    mapn[ma[v]][ma[u]]=val;
            }
            if(opr==>){
                if(mapn[ma[u]][ma[v]]>val)
                    mapn[ma[u]][ma[v]]=val;
            }
        }//建图
        //cout<<len<<endl;
        //for(int i=0;i<n;i++){
        //    for(int j=0;j<n;j++){
        //        cout<<mapn[i][j]<<" ";
        //    }
        //    cout<<endl;
        //}
        floyd();
        cur=0;
        int lost=ma[city[0]];
        for(int i=1;i<=c;i++){
            cur+=mapn[lost][ma[city[i]]]+mapn[ma[city[i]]][lost];
            //cout<<mapn[lost][ma[city[i]]]<<endl;
        }
        printf("%d. %d\n",Case++,cur);
    }
    return 0;
}

 

Einbahnstrasse

标签:键值   ace   where   lin   har   gem   mem   std   travel   

原文地址:http://www.cnblogs.com/wuwangchuxin0924/p/6188310.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!