码迷,mamicode.com
首页 > 其他好文 > 详细

Who's in the Middle[HDU1157]

时间:2016-12-18 15:13:49      阅读:141      评论:0      收藏:0      [点我收藏+]

标签:contract   and   iss   scanf   microsoft   blocks   median   others   title   

Who‘s in the Middle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16668    Accepted Submission(s): 7471


Problem Description
FJ is surveying his herd to find the most average cow. He wants to know how much milk this ‘median‘ cow gives: half of the cows give as much or more than the median; half give as much or less.

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
 

 

Input
* Line 1: A single integer N

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
 

 

Output
* Line 1: A single integer that is the median milk output.
 

 

Sample Input
5
2
4
1
3
5
 

 

Sample Output
3
Hint
INPUT DETAILS: Five cows with milk outputs of 1..5 OUTPUT DETAILS: 1 and 2 are below 3; 4 and 5 are above 3.
 
技术分享
#include<stdio.h>
#include<algorithm>
using namespace std;
int a[10010];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<n;i++)
             scanf("%d",&a[i]);
        sort(a,a+n);
        printf("%d\n",a[n/2]);
    }    
    return 0;
} 
View Code

 

Who's in the Middle[HDU1157]

标签:contract   and   iss   scanf   microsoft   blocks   median   others   title   

原文地址:http://www.cnblogs.com/dramstadt/p/6194382.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!