码迷,mamicode.com
首页 > 其他好文 > 详细

Employment Planning[HDU1158]

时间:2016-12-21 16:04:04      阅读:162      评论:0      收藏:0      [点我收藏+]

标签:nbsp   mit   esc   one   onclick   memory   each   display   div   

Employment Planning

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5292 Accepted Submission(s): 2262


Problem Description
A project manager wants to determine the number of the workers needed in every month. He does know the minimal number of the workers needed in each month. When he hires or fires a worker, there will be some extra cost. Once a worker is hired, he will get the salary even if he is not working. The manager knows the costs of hiring a worker, firing a worker, and the salary of a worker. Then the manager will confront such a problem: how many workers he will hire or fire each month in order to keep the lowest total cost of the project.

Input
The input may contain several data sets. Each data set contains three lines. First line contains the months of the project planed to use which is no more than 12. The second line contains the cost of hiring a worker, the amount of the salary, the cost of firing a worker. The third line contains several numbers, which represent the minimal number of the workers needed each month. The input is terminated by line containing a single ‘0‘.

Output
The output contains one line. The minimal total cost of the project.

Sample Input
3
4 5 6
10 9 11
0

Sample Output
199

技术分享
#include<stdio.h>
#include<string.h>

const int INF=99999999;

int dp[15][10010];
int people[15];

int main(){

    //freopen("input.txt","r",stdin);

    int n;
    int hire,salary,fire;
    while(scanf("%d",&n) && n){
        scanf("%d%d%d",&hire,&salary,&fire);
        int max_people=0;
        int i,j,k;
        for(i=1;i<=n;i++){
            scanf("%d",&people[i]);
            if(max_people<people[i])
                max_people=people[i];
        }
        for(i=people[1];i<=max_people;i++)      //初始化第一个月
            dp[1][i]=i*salary+i*hire;
        int min;
        for(i=2;i<=n;i++){
            for(j=people[i];j<=max_people;j++){
                min=INF;        //有了这个前面就不需要用O(n^2)初始化dp了。
                for(k=people[i-1];k<=max_people;k++)
                    if(min>dp[i-1][k]+(j>=k?(j*salary+(j-k)*hire):(j*salary+(k-j)*fire)))
                        min=dp[i-1][k]+(j>=k?(j*salary+(j-k)*hire):(j*salary+(k-j)*fire));
                dp[i][j]=min;
            }
        }
        min=INF;
        for(i=people[n];i<=max_people;i++)
            if(min>dp[n][i])
                min=dp[n][i];
        printf("%d\n",min);
    }
    return 0;
}
View Code

 

Employment Planning[HDU1158]

标签:nbsp   mit   esc   one   onclick   memory   each   display   div   

原文地址:http://www.cnblogs.com/dramstadt/p/6207777.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!