码迷,mamicode.com
首页 > 其他好文 > 详细

zoj 1750 Idiomatic Phrases Game (dijkstra)

时间:2014-08-18 16:22:52      阅读:228      评论:0      收藏:0      [点我收藏+]

标签:style   color   io   strong   for   ar   art   cti   

Idiomatic Phrases Game

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Tom is playing a game called Idiomatic Phrases Game. An idiom consists of several Chinese characters and has a certain meaning. This game will give Tom two idioms. He should build a list of idioms and the list starts and ends with the two given idioms. For every two adjacent idioms, the last Chinese character of the former idiom should be the same as the first character of the latter one. For each time, Tom has a dictionary that he must pick idioms from and each idiom in the dictionary has a value indicates how long Tom will take to find the next proper idiom in the final list. Now you are asked to write a program to compute the shortest time Tom will take by giving you the idiom dictionary.

Input

The input consists of several test cases. Each test case contains an idiom dictionary. The dictionary is started by an integer N (0 < N < 1000) in one line. The following is N lines. Each line contains an integer T (the time Tom will take to work out) and an idiom. One idiom consists of several Chinese characters (at least 3) and one Chinese character consists of four hex digit (i.e., 0 to 9 and A to F). Note that the first and last idioms in the dictionary are the source and target idioms in the game. The input ends up with a case that N = 0. Do not process this case.

Output

One line for each case. Output an integer indicating the shortest time Tome will take. If the list can not be built, please output -1.

Sample Input

5
5 12345978ABCD2341
5 23415608ACBD3412
7 34125678AEFD4123
15 23415673ACC34123
4 41235673FBCD2156
2
20 12345678ABCD
30 DCBF5432167D
0

Sample Output

17
-1

题意:成语接龙,一个字符的后四个字符和另一个字符的前四个字符相同,则连一条边,求0至n-1的最短路。

#include"stdio.h"
#include"string.h"
#include"queue"
#include"algorithm"
using namespace std;
#define N 1005
#define inf 0x7fffffff
int mark[N],g[N][N];
int dis[N];
struct node
{
    char s1[5],s2[5];
    int w;
}e[N];
void dijkstra(int s,int n)
{
    int i,u,min;
    for(i=0;i<n;i++)
        dis[i]=g[s][i];
    memset(mark,0,sizeof(mark));
    mark[s]=1;
    while(1)
    {
        u=0;
        min=inf;
        for(i=0;i<n;i++)
        {
            if(!mark[i]&&dis[i]<min)
            {
                min=dis[i];
                u=i;
            }
        }
        if(u==0)
            break;
        mark[u]=1;
        for(i=0;i<n;i++)
        {
            if(!mark[i]&&g[u][i]<inf&&dis[i]>dis[u]+g[u][i])
            {
                dis[i]=dis[u]+g[u][i];
            }
        }
    }
    if(dis[n-1]<inf)
        printf("%d\n",dis[n-1]);
    else
        printf("-1\n");
}
int main()
{
    int i,j,k,n,w;
    char str[50];
    while(scanf("%d",&n),n)
    {
        for(i=0;i<n;i++)
        {
            scanf("%d %s",&w,&str);
            int m=strlen(str);
            for(j=0;j<4;j++)
                e[i].s1[j]=str[j];
            e[i].s1[j]='\0';
            for(k=0,j=m-4;j<m;j++)
                e[i].s2[k++]=str[j];
            e[i].s2[k]='\0';
            e[i].w=w;
        }
        for(i=0;i<n;i++)
        {
            for(j=0;j<n;j++)
            {
                g[i][j]=(i==j?0:inf);
                if(strcmp(e[i].s2,e[j].s1)==0)
                    g[i][j]=e[i].w;
                if(strcmp(e[i].s1,e[j].s2)==0)
                    g[j][i]=e[j].w;
            }
        }
        dijkstra(0,n);
    }
    return 0;
}




zoj 1750 Idiomatic Phrases Game (dijkstra),布布扣,bubuko.com

zoj 1750 Idiomatic Phrases Game (dijkstra)

标签:style   color   io   strong   for   ar   art   cti   

原文地址:http://blog.csdn.net/u011721440/article/details/38661665

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!