码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1503 Integer Inquiry(多个大数相加)

时间:2014-08-18 16:29:52      阅读:193      评论:0      收藏:0      [点我收藏+]

标签:poj   大数   多个大数相加   

题目链接:http://poj.org/problem?id=1503


Description

One of the first users of BIT‘s new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers. 
``This supercomputer is great,‘‘ remarked Chip. ``I only wish Timothy were here to see these results.‘‘ (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.) 

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative). 

The final input line will contain a single zero on a line by itself. 

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670

Source


题意:就是给出多个大数,求它们的和!

下面给出两种代码:

代码一:

#include <cstdio>
#include <cstring>
const int MAXN = 117;
int main()
{
    char s[MAXN];
    int sum[MAXN] = {0};
    int i, j;
    while(gets(s))
    {
        int len = strlen(s);
        if(s[0] == '0' && len == 1)
            break;
        for(i = 110, j = len-1; j >= 0; i--, j--)
        {
            sum[i] += s[j]-'0';
        }
    }
    for(i = 110; i > 0; i--)
    {
        sum[i-1] += sum[i] / 10;
        sum[i] %= 10;
    }
    for(i = 0; sum[i] == 0 && i < 111; i++)
    {
        if(i == 111)//意味着全为零
        {
            printf("0\n");
        }
    }
    for( ; i < 111; i++)
    {
        printf("%d",sum[i]);
    }
    printf("\n");
    return 0;
}


代码二:

#include <cstdio>
#include <cstring>
const int MAXN = 117;
int main()
{
    char s[MAXN][MAXN];
    int maxx = -1, r = 0;
    for(int i = 0; ; i++)
    {
        gets(s[i]);
        int len = strlen(s[i]);
        if(len > maxx)//寻找最长的长度
            maxx = len;
        if(s[i][0] == '0' && len == 1)
            break;
        r++;
    }
    int c[MAXN], l = 0;
    int p = 0;//进位
    for(int i = maxx-1; i >= 0; i--)
    {
        int sum = 0;
        for(int j = 0; j < r; j++)
        {
            sum+=s[j][i]-'0';
        }
        sum += p;
        if(sum > 9)
        {
            p = sum/10;
            sum %=10;
        }
        else
            p = 0;
        c[l++] = sum;
        if(i == 0 && p != 0)
            c[l++] = p;
    }
    for(int i = l-1; i >= 0; i--)
    {
        printf("%d",c[i]);
    }
    printf("\n");
    return 0;
}


bubuko.com,布布扣

poj 1503 Integer Inquiry(多个大数相加),布布扣,bubuko.com

poj 1503 Integer Inquiry(多个大数相加)

标签:poj   大数   多个大数相加   

原文地址:http://blog.csdn.net/u012860063/article/details/38660691

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!