码迷,mamicode.com
首页 > 其他好文 > 详细

POJ3461 Oulipo[KMP]【学习笔记】

时间:2016-12-25 09:36:24      阅读:191      评论:0      收藏:0      [点我收藏+]

标签:algorithm   stream   class   cst   nat   scan   contain   command   顺序   

Oulipo
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 36916   Accepted: 14904

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e‘. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T‘s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A‘‘B‘‘C‘, …, ‘Z‘} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {‘A‘‘B‘‘C‘, …, ‘Z‘}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {‘A‘‘B‘‘C‘, …, ‘Z‘}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

Source


KMP裸题 出现几次
 
关于KMP
字符串从0开始,所以p[i]就是地i+1个字符
f[i]是失配函数,表示已经匹配了i个字符,i+1(就是p[i])失配转移到哪里
令j=f[i],就是说以位置i-1结尾的后缀包括了0...j-1这个前缀,再检查p[j]==s[i](即j+1  i+1)
技术分享
//
//  main.cpp
//  poj3461
//
//  Created by Candy on 10/19/16.
//  Copyright © 2016 Candy. All rights reserved.
//

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int N=1e6+5,M=1e4+5;
int T,f[M];// already i(0...i-1),now pos i
char s[N],p[M];
void getFail(){
    size_t m=strlen(p);
    f[0]=f[1]=0;
    for(int i=1;i<m;i++){
        int j=f[i];
        while(j&&p[i]!=p[j]) j=f[j];
        f[i+1]=p[i]==p[j]?j+1:0;
    }
}
int kmp(){
    getFail();
    int cnt=0;
    size_t n=strlen(s),m=strlen(p);
    int j=0;
    for(int i=0;i<n;i++){
        while(j&&s[i]!=p[j]) j=f[j];
        if(s[i]==p[j]) j++;
        if(j==m) cnt++;
    }
    return cnt;
}
int main(int argc, const char * argv[]) {
    scanf("%d",&T);
    while(T--){
        scanf("%s%s",p,s);
        printf("%d\n",kmp());
    }
    
    return 0;
}
以前愚蠢的从0开始

从0开始太愚蠢了,于是我从1开始重学重写了一遍

1.算法理解(orz 阮一峰):http://www.ruanyifeng.com/blog/2013/05/Knuth%E2%80%93Morris%E2%80%93Pratt_algorithm.html

2.摘抄(修改)课件:

  • 定义f[i]表示A[1,i]的长度为f[i]的后缀等于A[1,f[i]]  也就是说对于这个子串来说f[i]长度的前缀和后缀相等(注意顺序都是从左到右相等),那么j+1位置匹配失败就可以转移到f[j]位置(因为1..f[j]和刚刚成功的后缀是一样的)继续匹配f[j]+1
  • 多个f[i]符合条件时,取最大的。当然,f[i]是要小于i的,否则就没有意义了。
  • 将i从2到n枚举(f[1]=0是不必计算的),依次计算f[i]。
    计算f[i]时,先令j=f[i-1],f[i]最大只会是j+1。只需判断A[i]与A[j+1]是否相等就能判断f[i]是不是j+1。若相等,f[i]=j+1;否则令j=f[j],继续这个过程。
    如果j=0后仍然和j+1不相等,就使f[i]=0

  • 时间复杂度O(n),因为j最多增加减少n次

 

//
//  main.cpp
//  poj3461
//
//  Created by Candy on 10/19/16.
//  Copyright ? 2016 Candy. All rights reserved.
//

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int N=1e6+5,M=1e4+5;
int T,f[M],n,m;
char t[N],p[M];
void getFail(){
    f[1]=0;
    for(int i=2;i<=m;i++){
        int j=f[i-1];
        while(j&&p[i]!=p[j+1]) j=f[j];
        f[i]=p[i]==p[j+1]?j+1:0;
    }
}
int kmp(){
    int ans=0;
    getFail();
    int j=0;
    for(int i=1;i<=n;i++){
        while(j&&t[i]!=p[j+1]) j=f[j];
        j+=t[i]==p[j+1];
        if(j==m) ans++;
    }
    return ans;
}
int main(){
//    freopen("in.txt","r",stdin);
    scanf("%d",&T);
    while(T--){
        scanf("%s%s",p+1,t+1);
        n=strlen(t+1),m=strlen(p+1);
        printf("%d\n",kmp());
    }
    
    return 0;
}

 

 

 

 

POJ3461 Oulipo[KMP]【学习笔记】

标签:algorithm   stream   class   cst   nat   scan   contain   command   顺序   

原文地址:http://www.cnblogs.com/candy99/p/5976855.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!