码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1703 Find them, Catch them

时间:2014-08-18 20:02:12      阅读:236      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   os   io   strong   

链接:

http://poj.org/problem?id=1703

题目:

Find them, Catch them

Time Limit: 1000MS
Memory Limit: 10000K

Total Submissions: 22289
Accepted: 6648

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 
Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 
1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 
2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source

POJ Monthly--2004.07.18

 

本题是POJ 1182的简化版, union_set两个方向合并都可以

代码一次就写对了,但是输出different情况时候少了个s,晕个半死。。。。

 

#include<cstdio>
#include<cstring>
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
const int maxn=100000+5;
int p[maxn], r[maxn];

void make_set()
{
    memset(p, -1, sizeof(p));
    memset(r, 0, sizeof(r));
}

int find_set(int x)
{
    if(p[x]==-1)
        return x;
    int fx=p[x];
    p[x]=find_set(p[x]);
    r[x]=(r[x]+r[fx])%2;
    return p[x];
}

void union_set(int x, int y, int d)
{
    int fx=find_set(x), fy=find_set(y);
    if(fx==fy) return;
#if 0
    p[fx]=fy;
    r[fx]=(2-r[x]+d+r[y])%2;
#else
    p[fy]=fx;
    r[fy]=(2-r[y]+d+r[x])%2;
#endif
}

int main()
{
    int T;
    int N, M;
    scanf("%d", &T);
    while(T--) {
        scanf("%d%d", &N, &M);
        make_set();
        char c[20]; int x, y;
        for(int i=0;i<M;i++)
        {
            scanf("%s%d%d", c, &x, &y);
            if(c[0]==A)
            {
                if(find_set(x)==find_set(y))
                {
                    if(r[x]==r[y])
                        printf("In the same gang.\n");
                    else
                        printf("In different gangs.\n");
                }
                else
                    printf("Not sure yet.\n");
            }
            else if(c[0]==D)
            {
                union_set(x, y, 1);
            }
        }
    }
    return 0;
}

poj 1703 Find them, Catch them,布布扣,bubuko.com

poj 1703 Find them, Catch them

标签:des   style   blog   http   color   os   io   strong   

原文地址:http://www.cnblogs.com/cute/p/3920127.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!