码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 3507 Print Article

时间:2014-08-18 22:09:43      阅读:322      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   java   os   io   strong   


斜率优化DP


Print Article

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 5519    Accepted Submission(s): 1707


Problem Description
Zero has an old printer that doesn‘t work well sometimes. As it is antique, he still like to use it to print articles. But it is too old to work for a long time and it will certainly wear and tear, so Zero use a cost to evaluate this degree.
One day Zero want to print an article which has N words, and each word i has a cost Ci to be printed. Also, Zero know that print k words in one line will cost
bubuko.com,布布扣

M is a const number.
Now Zero want to know the minimum cost in order to arrange the article perfectly.
 

Input
There are many test cases. For each test case, There are two numbers N and M in the first line (0 ≤ n ≤ 500000, 0 ≤ M ≤ 1000). Then, there are N numbers in the next 2 to N + 1 lines. Input are terminated by EOF.
 

Output
A single number, meaning the mininum cost to print the article.
 

Sample Input
5 5 5 9 5 7 5
 

Sample Output
230
 

Author
Xnozero
 

Source
 


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int maxn=500500;

int n;
int q[maxn],head,tail;
int dp[maxn],sum[maxn],M;

int main()
{
    while(scanf("%d%d",&n,&M)!=EOF)
    {
        head=0,tail=0,dp[0]=0,sum[0]=0;
        q[tail++]=0;

        for(int i=1;i<=n;i++)
        {
            scanf("%d",sum+i);
            sum[i]+=sum[i-1];
        }

        for(int i=1;i<=n;i++)
        {
            while(head+1<tail)
            {
                int p1=q[head];
                int p2=q[head+1];
                int x1=dp[p1]+sum[p1]*sum[p1];
                int x2=dp[p2]+sum[p2]*sum[p2];
                int y1=sum[p1];
                int y2=sum[p2];
                if( (x2-x1) <= (y2-y1) * 2 * sum[i] ) head++;
                else break;
            }
            int k=q[head];
            dp[i]=dp[k]+(sum[i]-sum[k])*(sum[i]-sum[k])+M;
            while(head+1<tail)
            {
                int p1=q[tail-2];
                int p2=q[tail-1];
                int p3=i;
                int x1=dp[p1]+sum[p1]*sum[p1];
                int x2=dp[p2]+sum[p2]*sum[p2];
                int x3=dp[p3]+sum[p3]*sum[p3];
                int y1=sum[p1],y2=sum[p2],y3=sum[p3];
                if((x3-x2)*(y2-y1)<=(x2-x1)*(y3-y2))
                    tail--;
                else break;
            }
            q[tail++]=i;
        }
       printf("%d\n",dp[n]);
    }
    return 0;
}




HDOJ 3507 Print Article,布布扣,bubuko.com

HDOJ 3507 Print Article

标签:des   style   http   color   java   os   io   strong   

原文地址:http://blog.csdn.net/ck_boss/article/details/38665835

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!