码迷,mamicode.com
首页 > 其他好文 > 详细

NOI 1.5 42:画矩形

时间:2017-01-07 22:50:09      阅读:1419      评论:0      收藏:0      [点我收藏+]

标签:page   space   otto   ble   bottom   style   pre   bit   top   

 

描述

根据参数,画出矩形。

输入
输入一行,包括四个参数:前两个参数为整数,依次代表矩形的高和宽(高不少于3行不多于10行,宽不少于5列不多于10列);第三个参数是一个字符,表示用来画图的矩形符号;第四个参数为1或0,0代表空心,1代表实心。
输出
输出画出的图形。
样例输入
7 7 @ 0
样例输出
@@@@@@@
@     @
@     @
@     @
@     @
@     @
@@@@@@@




法一
  • #include<iostream>
    #include<cstdio>
    #include<cstdlib>
    using namespace std;
    int main()
    {
        int a,b;
        char ch;
        bool c;
        cin>>a>>b>>ch>>c;
        if(c==1)
        { 
          for(int i=1;i<=a;i++)
             {
               for(int j=1;j<=b;j++)
                   cout<<ch;
               cout<<endl;               
             } 
        }
        else
        {
          for(int i=1;i<=a;i++) cout<<ch;
          cout<<endl;
          for(int i=2;i<a;i++)
          {
            for(int j=1;j<=b;j++)
            {
            if(j==1||j==b) cout<<ch;
            else cout<<" ";
            }
            cout<<endl;
          }
          for(int i=1;i<=a;i++) cout<<ch;
        }
       return 0;
    }

     

  •  
  • 法二
    #include<bits/stdc++.h>
    using namespace std;
    int m,n,q;
    char fil,wai;
    int main()
    {
    cin>>m>>n>>wai>>q;
    if(q==0) fil= ;
    if(q==1) fil=wai;
    for(int i=1;i<=m;i++)
    {
    for(int j=1;j<=n;j++)
    {
    if(i==1||i==m||j==1||j==n) cout<<wai;
    else cout<<fil;
    }
    cout<<endl;
    }
    return 0;    
    }

     

  •  
  •  
  •  
  •  

NOI 1.5 42:画矩形

标签:page   space   otto   ble   bottom   style   pre   bit   top   

原文地址:http://www.cnblogs.com/z360/p/6260409.html

(2)
(1)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!