码迷,mamicode.com
首页 > 其他好文 > 详细

UVA 100 The 3n + 1 problem(超级大水题)

时间:2014-08-19 12:57:54      阅读:248      评论:0      收藏:0      [点我收藏+]

标签:uva




 The 3n + 1 problem
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

 

Consider the following algorithm:

 
1. input n

2. print n

3. if n = 1 then STOP

4. if n is odd then bubuko.com,布布扣

5. else bubuko.com,布布扣

6. GOTO 2

 

Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)

Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given n this is called the cycle-lengthof n. In the example above, the cycle length of 22 is 16.

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.

Input

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including iand j.

You can assume that no operation overflows a 32-bit integer.

Output

For each pair of input integers i and j you should output ij, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

Sample Input

1 10
100 200
201 210
900 1000

Sample Output

1 10 20
100 200 125
201 210 89
900 1000 174

题目大意:

输出i到j中循环次数最多的。

解题思路:

唯一的坑点是i,j输入的大小关系是不确定的。


代码:

#include<iostream>
#include<cstdio>

using namespace std;

int main(){
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF){
        int maxn=0;
        printf("%d %d ",n,m);
        if(n>m){
            int temp=n;n=m;m=temp;
        }
        for(int i=n;i<=m;i++){
            int j=i,cnt=1;
            while(j!=1){
                if(j%2==0){
                    j=j/2;
                    cnt++;
                }
                else {
                    j=3*j+1;
                    cnt++;
                }
            }
            if(cnt>maxn){
                maxn=cnt;
            }
        }
    printf("%d\n",maxn);
    }
    return 0;
}



UVA 100 The 3n + 1 problem(超级大水题),布布扣,bubuko.com

UVA 100 The 3n + 1 problem(超级大水题)

标签:uva

原文地址:http://blog.csdn.net/hush_lei/article/details/38679059

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!