码迷,mamicode.com
首页 > 其他好文 > 详细

Kattis - Virtual Friends

时间:2017-01-12 21:15:05      阅读:222      评论:0      收藏:0      [点我收藏+]

标签:amp   roo   begin   out   thml   website   letter   using   integer   

Virtual Friends

These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends’ friends, their friends’ friends’ friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends.

Your task is to observe the interactions on such a website and keep track of the size of each person’s network.

Assume that every friendship is mutual. If Fred is Barney’s friend, then Barney is also Fred’s friend.

Input

The first line of input contains one integer specifying the number of test cases to follow. Each test case begins with a line containing an integer FF, the number of friendships formed, which is no more than 100000100000. Each of the following FF lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase).

Output

Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.

Sample Input 1Sample Output 1
1
3
Fred Barney
Barney Betty
Betty Wilma
2
3
4

题意

朋友的朋友也是朋友,问当前的人有几个朋友

思路

并查集

代码

#include<bits/stdc++.h>
using namespace std;
int Set[200010];
int Num[200010];
int Findroot(int x) {
    if(x = Set[x])
        return x;
    return Set[x] = Findroot(Set[x]);
}
void Union(int x, int y) {
    x = Findroot(x);
    y = Findroot(y);
    if(x != y) {
        Set[x] = y;
        Num[y] += Num[x];
    }
    cout << Num[y] << endl;
}
int main() {
    int t;
    cin >> t;
    while(t--) {
        int n;
        cin >> n;
        map<string, int> Map;
        for (int i = 0; i <= 2 * n; ++i) {
            Set[i] = i;
            Num[i] = 1;
        }
        string A, B;
        for (int i = 0, j = 1; i < n; ++i) {
            cin >> A >> B;
            if (!Map[A]) Map[A] = j++;
            if (!Map[B]) Map[B] = j++;
            Union(Map[A], Map[B]);
        }
    }
}

 

Kattis - Virtual Friends

标签:amp   roo   begin   out   thml   website   letter   using   integer   

原文地址:http://www.cnblogs.com/zhien-aa/p/6279634.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!