码迷,mamicode.com
首页 > 其他好文 > 详细

Kattis - CD

时间:2017-01-13 22:17:16      阅读:203      评论:0      收藏:0      [点我收藏+]

标签:last   not   mem   cout   mina   ted   style   nat   const   

CD

Jack and Jill have decided to sell some of their Compact Discs, while they still have some value. They have decided to sell one of each of the CD titles that they both own. How many CDs can Jack and Jill sell?

Neither Jack nor Jill owns more than one copy of each CD.

Input

The input consists of a sequence of test cases. The first line of each test case contains two non-negative integersNN and MM, each at most one million, specifying the number of CDs owned by Jack and by Jill, respectively. This line is followed by NN lines listing the catalog numbers of the CDs owned by Jack in increasing order, and MMmore lines listing the catalog numbers of the CDs owned by Jill in increasing order. Each catalog number is a positive integer no greater than one billion. The input is terminated by a line containing two zeros. This last line is not a test case and should not be processed.

Output

For each test case, output a line containing one integer, the number of CDs that Jack and Jill both own.

Sample Input 1Sample Output 1
3 3
1
2
3
1
2
4
0 0
2

题意

计算两个人的CD的序号有多少个相同的

代码

#include<bits/stdc++.h>
using namespace std;
#define LL long long
const int maxn = 10010000;
LL n, m;
LL a[maxn];
int main() {
    while(cin >> n >> m) {
        if(n == m && n == 0)
            break;
        LL x, cnt = 0;
        memset(a, 0, sizeof(a));
        for(LL i = 0; i < n; i++) {
            cin >> x;
            a[x] = 1;
        }
        for(LL i = 0; i < m; i++) {
            cin >> x;
            if(a[x])
                cnt++;
        }
        cout << cnt << endl;
    }
}

 

Kattis - CD

标签:last   not   mem   cout   mina   ted   style   nat   const   

原文地址:http://www.cnblogs.com/zhien-aa/p/6284077.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!