码迷,mamicode.com
首页 > 其他好文 > 详细

POJ3177 Redundant Paths 双连通分量

时间:2017-01-16 21:29:01      阅读:281      评论:0      收藏:0      [点我收藏+]

标签:判断   space   pos   题意   possible   ever   media   size   决定   

Redundant Paths

Description

In order to get from one of the F (1 <= F <= 5,000) grazing fields (which are numbered 1..F) to another field, Bessie and the rest of the herd are forced to cross near the Tree of Rotten Apples. The cows are now tired of often being forced to take a particular path and want to build some new paths so that they will always have a choice of at least two separate routes between any pair of fields. They currently have at least one route between each pair of fields and want to have at least two. Of course, they can only travel on Official Paths when they move from one field to another. 

Given a description of the current set of R (F-1 <= R <= 10,000) paths that each connect exactly two different fields, determine the minimum number of new paths (each of which connects exactly two fields) that must be built so that there are at least two separate routes between any pair of fields. Routes are considered separate if they use none of the same paths, even if they visit the same intermediate field along the way. 

There might already be more than one paths between the same pair of fields, and you may also build a new path that connects the same fields as some other path.

Input

Line 1: Two space-separated integers: F and R 

Lines 2..R+1: Each line contains two space-separated integers which are the fields at the endpoints of some path.

Output

Line 1: A single integer that is the number of new paths that must be built.

Sample Input

7 7
1 2
2 3
3 4
2 5
4 5
5 6
5 7

Sample Output

2

Hint

Explanation of the sample: 

One visualization of the paths is: 
   1   2   3
+---+---+
| |
| |
6 +---+---+ 4
/ 5
/
/
7 +
Building new paths from 1 to 6 and from 4 to 7 satisfies the conditions. 
   1   2   3
+---+---+
: | |
: | |
6 +---+---+ 4
/ 5 :
/ :
/ :
7 + - - - -
Check some of the routes: 
1 – 2: 1 –> 2 and 1 –> 6 –> 5 –> 2 
1 – 4: 1 –> 2 –> 3 –> 4 and 1 –> 6 –> 5 –> 4 
3 – 7: 3 –> 4 –> 7 and 3 –> 2 –> 5 –> 7 
Every pair of fields is, in fact, connected by two routes. 

It‘s possible that adding some other path will also solve the problem (like one from 6 to 7). Adding two paths, however, is the minimum.
 
题意:为了保护放牧环境,避免牲畜过度啃咬同一个地方的草皮,牧场主决定利用不断迁移牲畜进行喂养的方法去保护牧草。然而牲畜在迁移过程中也会啃食路上的牧草,所以如果每次迁移都用同一条道路,那么该条道路同样会被啃咬过度而遭受破坏。现在牧场主拥有F个农场,已知这些农场至少有一条路径连接起来(不一定是直接相连),但从某些农场去另外一些农场,至少有一条路可通行。为了保护道路上的牧草,农场主希望再建造若干条道路,使得每次迁移牲畜时,至少有2种迁移途径,避免重复走上次迁移的道路。已知当前有的R条道路,问农场主至少要新建造几条道路,才能满足要求?

题解:把F个农场看作点、路看作边构造一个无向图G时,图G不存在桥。

也就是问给定一个连通的无向图G,至少要添加几条边,才能使其变为双连通图。

把每一个双连通分量(内部满足条件)缩为一个点,形成一棵树,加(n+1)/2条边就是双连通了(度为1的点个数为n)

注意:判断两个点是不是同一个双连通分量

1.无重边:low值相等就是同一个双连通分量

2.有重边:bfs结束时出栈的就是同一连通分量,好像有点麻烦

这里加了一个判断,不加重边

 

#include<stdio.h>
#include <algorithm>
#include <string.h>
#define N 5005
#define mes(x) memset(x, 0, sizeof(x));
#define ll __int64
const long long mod = 1e9+7;
const int MAX = 0x7ffffff;
using namespace std;
struct ed{
    int to, next;
}edge[N*5];
int head[N], top=0;
bool mp[N][N];
int pre[N], low[N], dfs_time, out[N];
void addedge(int u,int v){
    edge[top].to = v;
    edge[top].next = head[u];
    head[u] = top++;
}
void dfs(int u,int father){
    low[u] = pre[u] = dfs_time++;
    for(int i=head[u];i!=-1;i=edge[i].next){
        int v = edge[i].to;
        if(v == father) continue;
        if(!pre[v]){
            dfs(v, u);
            low[u] = min(low[v], low[u]);
        }
        else low[u] = min(low[u], pre[v]);
    }
}
int main(){
    int n, m, t, i, j, a, b;
    while(~scanf("%d%d", &n, &m)){
        memset(head, -1, sizeof(head));
        memset(pre,0,sizeof(pre));
        memset(low, 0, sizeof(low));
        memset(out, 0, sizeof(out));
        memset(mp, false, sizeof(mp));
        dfs_time = 1;top = 0;
        for(i=1;i<=m;i++){
            scanf("%d%d", &a, &b);
            if(!mp[a][b]){
            mp[a][b] = mp[b][a] = 1;
            addedge(a, b);
            addedge(b, a);
            }
        }
        dfs(1,-1);
        t = 0;
        for(i=1;i<=n;i++)
            for(j=head[i];j!=-1;j=edge[j].next){
                int v = edge[j].to;
                if(low[v] != low[i])
                    out[low[i]]++;
            }
        for(i=1;i<=n;i++)
            if(out[i] == 1)
                t++;
        printf("%d\n", (t+1)/2);
    }
}

 

POJ3177 Redundant Paths 双连通分量

标签:判断   space   pos   题意   possible   ever   media   size   决定   

原文地址:http://www.cnblogs.com/Noevon/p/6290905.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!