码迷,mamicode.com
首页 > 其他好文 > 详细

Zjnu Stadium(加权并查集)

时间:2017-01-17 23:40:41      阅读:268      评论:0      收藏:0      [点我收藏+]

标签:not   make   void   before   img   using   normal   style   问题解决   

Zjnu Stadium

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3186    Accepted Submission(s): 1226


Problem Description
In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1--300, counted clockwise, we assume the number of rows were infinite.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1--N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.
 

 

Input
There are many test cases:
For every case:
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.

Output
For every case:
Output R, represents the number of incorrect request.
 
Sample Input
10 10 1 2 150 3 4 200 1 5 270 2 6 200 6 5 80 4 7 150 8 9 100 4 8 50 1 7 100 9 2 100
 

 

Sample Output
2
题目大意:

有n个人坐在zjnu体育馆里面,然后给出m个他们之间的距离, A B X, 代表B的座位比A多X. 然后求出这m个关系之间有多少个错误,所谓错误就是当前这个关系与之前的有冲突。

 
 

教训:

又一次为多组数据所伤。输入不完整,初始化不彻底,不要再重蹈覆辙了。
 

思路:

这题真的是个加权并查集。。。
输入的x,y,z可以看做是从x指向y的一条边,这条边的边权需要修改为z
确定一个根节点,暂且取名为root。way[i]表示i点到他所对应的根节点的距离
在连接时,有一个式子比较难懂  way[y1]=way[x]+z-way[y];可以看图分析
技术分享
不难看出  way[root2]+way[y]==way[x]+z  而此时的way[root2]==way[y1]  问题解决
剩下的就是朴素的加权并查集问题了
 
#include<iostream>
#include<cstdio>
using namespace std;
#define MAXN 50010
int n,m,father[MAXN],way[MAXN],ans;
void before()
{
    for(int i=0;i<MAXN;i++)father[i]=i,way[i]=0;
    ans=0;
}
int find(int x)
{
    if(x==father[x])return father[x];
    int fa=father[x];
    father[x]=find(father[x]);
    way[x]+=way[fa];
    return father[x];
}
void unit(int x,int y,int x1,int y1,int z)
{
    father[y1]=x1;
    way[y1]=way[x]+z-way[y];
}
int main()
{
    while(scanf("%d%d",&n,&m)==2)
    {
        before();
        int x,y,z;
        while(m--)
        {
            scanf("%d%d%d",&x,&y,&z);
            int f1=find(x),f2=find(y);
            if(f1!=f2)unit(x,y,f1,f2,z);
            else if(way[y]-way[x]!=z)ans++;
        }
        printf("%d\n",ans);
    }
}

 

Zjnu Stadium(加权并查集)

标签:not   make   void   before   img   using   normal   style   问题解决   

原文地址:http://www.cnblogs.com/thmyl/p/6294860.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!