码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ3197 Google Book 【贪心】

时间:2014-08-19 16:38:05      阅读:222      评论:0      收藏:0      [点我收藏+]

标签:zoj3197

Google Book

Time Limit: 1 Second      Memory Limit: 32768 KB

You, the best hacker in the world, want to download the books published on Google Book. After some investigation, you found that the address of each page consists of two parts. The first part is the page number, the second part is the signature which is unique for each page. To get the signature, you can send the query to the server. The query has one parameter, which indicates the page number. The server will return the signature of the required page, and it may also return the signature of some adjacent pages.

To minimize the bytes downloaded from the internet, and also make the server adminstrator hard to notice your "hack", you‘d like to minimize the number of queries

Input

The input has multiple cases.
The first line of the input is a single integer T which is the number of test cases. Then T consecutive test cases follow. In each test case, the first line is a number N (1<=N<=5000), indicating the number of pages of the book. Then n lines follows. On the i-th line, there will be two integers ai and bi (ai<=i<=bi). They indicate that the query for the i-th page will return the signatures from page ai to page bi (inclusive)

Output

Results should be directed to standard output. The output of each test case should be a single integer, which is the minimum number of queries to get all the signatures.

Sample Input

2
3
1 1
2 2
3 3
3
1 1
1 3
3 3

Sample Output

3
1

#include <stdio.h>
#include <string.h>
#include <algorithm>
#define maxn 5002
using std::sort;

struct Node{
    int l, r;
} E[maxn];

bool cmp(Node a, Node b){
    if(a.l == b.l) return a.r > b.r;
    return a.l < b.l;
}

int main()
{
    int t, n, i, j, ans, flag, tmp;
    scanf("%d", &t);
    while(t--){
        scanf("%d", &n);
        for(i = 0; i < n; ++i)
            scanf("%d%d", &E[i].l, &E[i].r);
        sort(E, E + n, cmp);
        flag = E[0].r; ans = 1;
        for(i = 1; i < n; ++i){
            tmp = flag;
            for(j = i; j < n; ++j)
                if(E[j].l <= flag + 1){
                    if( E[j].r > tmp) tmp = E[j].r;
                }else{
                    flag = tmp; i = j - 1;
                    ++ans;
                    break;
                }
        }
        if(flag != n) ++ans;
        printf("%d\n", ans);
    }
    return 0;
}


ZOJ3197 Google Book 【贪心】,布布扣,bubuko.com

ZOJ3197 Google Book 【贪心】

标签:zoj3197

原文地址:http://blog.csdn.net/chang_mu/article/details/38682139

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!