码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1914 稳定婚姻匹配

时间:2017-01-18 13:54:44      阅读:234      评论:0      收藏:0      [点我收藏+]

标签:lines   members   order   blog   which   span   field   ios   miss   

The Stable Marriage Problem

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 758    Accepted Submission(s): 389


Problem Description
The stable marriage problem consists of matching members of two different sets according to the member’s preferences for the other set’s members. The input for our problem consists of:

a set M of n males;
a set F of n females;

for each male and female we have a list of all the members of the opposite gender in order of preference (from the most preferable to the least).
A marriage is a one-to-one mapping between males and females. A marriage is called stable, if there is no pair (m, f) such that f ∈ F prefers m ∈ M to her current partner and m prefers f over his current partner. The stable marriage A is called male-optimal if there is no other stable marriage B, where any male matches a female he prefers more than the one assigned in A.

Given preferable lists of males and females, you must find the male-optimal stable marriage.

 

 

Input
The first line gives you the number of tests. The first line of each test case contains integer n (0 < n < 27). Next line describes n male and n female names. Male name is a lowercase letter, female name is an upper-case letter. Then go n lines, that describe preferable lists for males. Next n lines describe preferable lists for females.

 

 

Output
For each test case find and print the pairs of the stable marriage, which is male-optimal. The pairs in each test case must be printed in lexicographical order of their male names as shown in sample output. Output an empty line between test cases.

 

 

Sample Input
2
3
a b c A B C
a:BAC
b:BAC
c:ACB
A:acb
B:bac
C:cab
3
a b c A B C
a:ABC
b:ABC
c:BCA
A:bac
B:acb
C:abc
 

 

Sample Output
a A b B c C a B b A c C
 

 

Source
 题意:裸婚姻匹配,注意男士排序时的序号一定不要弄混了。
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<map>
#include<queue>
#include<algorithm>
using namespace std;
const int maxn=30;
int pref[maxn][maxn],ord[maxn][maxn],fum[maxn],fuw[maxn],nex[maxn];
int t,n;
char ch[30],s[35],x;
int nu[30];
map<char,int>vm,vw;
map<int,char>um,uw;
bool cmp(int x,int y)
{
    return ch[x]<ch[y];
}
queue<int>q;
void engage(int m,int w)
{
    int pm=fum[w];
    if(pm){
        fuw[pm]=0;
        q.push(pm);
    }
    fuw[m]=w;
    fum[w]=m;
}
int main()
{
    scanf("%d",&t);
    while(t--){
        memset(pref,0,sizeof(pref));
        vm.clear();vw.clear();um.clear();uw.clear();
        scanf("%d",&n);
        for(int i=1;i<=n;i++){
            cin>>ch[i];
            nu[i]=i;
        }
        sort(nu+1,nu+1+n,cmp);
        for(int i=1;i<=n;i++){
            int tmp=nu[i];
            vm[ch[tmp]]=tmp;
            um[tmp]=ch[tmp];
            fuw[tmp]=0;
            nex[tmp]=1;
            q.push(tmp);
        }
        for(int i=1;i<=n;i++){
            cin>>x;
            vw[x]=i;
            uw[i]=x;
            fum[i]=0;
        }
        for(int i=1;i<=n;i++){
            scanf("%s",s);
            int tmp=vm[s[0]];
            for(int j=2;j<n+2;j++){
                pref[tmp][j-1]=vw[s[j]];
            }
        }
        for(int i=1;i<=n;i++){
            scanf("%s",s);
            int tmp=vw[s[0]];
            for(int j=2;j<n+2;j++){
                ord[tmp][vm[s[j]]]=j-1;
            }
        }
        while(!q.empty()){
            int m=q.front();
            q.pop();
            int w=pref[m][nex[m]++];
            if(w==0) continue;
            if(!fum[w])
                engage(m,w);
            else if(ord[w][m]<ord[w][fum[w]])
                engage(m,w);
            else q.push(m);
        }
        while(!q.empty()) q.pop();
        for(int i=1;i<=n;i++){
            int tmp=nu[i];
            printf("%c %c\n",um[tmp],uw[fuw[tmp]]);
        }
        if(t!=0) printf("\n");
    }
    return 0;
}

 

HDU1914 稳定婚姻匹配

标签:lines   members   order   blog   which   span   field   ios   miss   

原文地址:http://www.cnblogs.com/--ZHIYUAN/p/6296222.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!