码迷,mamicode.com
首页 > 其他好文 > 详细

简单枚举-------计算对数

时间:2017-01-24 16:14:32      阅读:138      评论:0      收藏:0      [点我收藏+]

标签:stdio.h   ++   存在   while   include   turn   can   数据   blog   

给定两个正整数a(a>1)和b。可以知道一定存在整数x,使得

x <= logab < x + 1 或者 ax<= b < ax+1

请计算x。

Input两行,第一行是a,第二行是b。每个整数均不超过100位。Output一行,即对应的x。输入数据保证x不大于20。Sample Input

10000
1000000000001

Sample Output

3
#include<stdio.h>
double a,b,c;
int main()
{
    int x=0;
    scanf("%lf %lf",&a,&b);
    
        while(b>=a)
        {
            c=b/a;
            x++;
            b=c;
        }
    printf("%d",x);
    return 0;
}

  列出数学模型的话就好想了

样例:

10000*10000*10000<=1000000000001<10000*100000*10000*10000
x++
10000*10000<=100000000
x++
10000<=10000
x++

简单枚举-------计算对数

标签:stdio.h   ++   存在   while   include   turn   can   数据   blog   

原文地址:http://www.cnblogs.com/ljzh/p/6347239.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!