标签:strong written content output ret std inf stdio.h scan
Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input
Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.
Output
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input-1000000 9Sample Output
-999,991
#include <stdio.h>
int main()
{
int a = 0, b = 0, sum = 0, i = 0, j = 0;
char arr[20] = {0};
scanf("%d %d", &a, &b);
sum = a + b;
if (sum == 0)
{
printf("0\n");
return 0;
}
else if (sum < 0)
{
printf("-");
sum = -sum;
}
for (i = 0; sum > 0; i++)
{
if ( (i + 1) % 4 == 0)
{
arr[i] = ‘,‘;
i++;
}
arr[i] = sum % 10 + 48;
sum /= 10;
}
for (j = i - 1; j >= 0; j--)
{
printf("%c", arr[j]);
}
printf("\n");
return 0;
}
标签:strong written content output ret std inf stdio.h scan
原文地址:http://www.cnblogs.com/cbattle/p/6358864.html