码迷,mamicode.com
首页 > 其他好文 > 详细

A+B Format (20)

时间:2017-01-31 16:54:34      阅读:168      评论:0      收藏:0      [点我收藏+]

标签:strong   written   content   output   ret   std   inf   stdio.h   scan   

1001. A+B Format (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

 

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output
-999,991




#include <stdio.h>

int main()
{
int a = 0, b = 0, sum = 0, i = 0, j = 0;
char arr[20] = {0};
scanf("%d %d", &a, &b);
sum = a + b;
if (sum == 0)
{
printf("0\n");
return 0;
}
else if (sum < 0)
{
printf("-");
sum = -sum;
}

for (i = 0; sum > 0; i++)
{
if ( (i + 1) % 4 == 0)
{
arr[i] = ‘,‘;
i++;
}
arr[i] = sum % 10 + 48;
sum /= 10;
}

for (j = i - 1; j >= 0; j--)
{
printf("%c", arr[j]);
}
printf("\n");

return 0;
}




A+B Format (20)

标签:strong   written   content   output   ret   std   inf   stdio.h   scan   

原文地址:http://www.cnblogs.com/cbattle/p/6358864.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!