码迷,mamicode.com
首页 > 其他好文 > 详细

poj3723_Conscription

时间:2017-01-31 20:02:40      阅读:232      评论:0      收藏:0      [点我收藏+]

标签:turn   mount   font   ios   use   for   --   sed   logs   

Conscription
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12393   Accepted: 4350

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, NM and R.
Then R lines followed, each contains three integers xiyi and di.
There is a blank line before each test case.

1 ≤ NM ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223

Source

[Submit]   [Go Back]   [Status]   [Discuss]

刚开始差点理解错意思,原来是男女两种人,windy必须要买掉所有人是(N+M)*10000,然后每两个人认识会给windy减少d的花费,kruskal中按照从大到小排序即可。

另外也可以把-d存进去,那样kruskal中就不用修改了。

#include <iostream>
#include <cstdio>
#include <vector>
#include <queue>
#include <cstring>
#include <algorithm>
#include <cstdlib>
#define for(i,x,n) for(int i=x;i<n;i++)
#define ll long long int
#define INF 0x3f3f3f3f
#define MOD 1000000007
#define MAX_N 50005

using namespace std;

struct edge{int u,v,cost;};
edge es[MAX_N];
int V,E;

int par[MAX_N];
int depth[MAX_N];//记录每个节点下面到位深度

void init(int n)//初始化
    {for(i,0,n) {par[i]=i;depth[i]=1;}}
int findf(int t)//寻找根节点
    { return t==par[t] ? t:par[t]=findf(par[t]);}
bool same(int x,int y)//是否在同一组内
    {return findf(x)==findf(y);}
void unite(int t1,int t2){//成为一组
    int f1=findf(t1);
    int f2=findf(t2);
    if(f1==f2){
        return ;
    }
    if(depth[f1]<depth[f2]){
        par[f1]=f2;
    }else{
        par[f2]=f1;
        if(depth[f1]==depth[f2]){
            depth[f1]++;//记录深度
        }
    }
}

bool comp(edge a,edge b){
    return a.cost>b.cost;
}

int kruskal(){
    sort(es,es+E,comp);
    init(V);
    int res=0;
    for(i,0,E){
        edge e=es[i];
        if(!same(e.u,e.v)){
            unite(e.u,e.v);
            res+=e.cost;
        }
    }
    return res;
}

int main()
{
    //freopen("data.txt", "r", stdin);
    //freopen("data.out", "w", stdout);
    int N,M,R;
    int x,y,d;
    int n;
    scanf("%d",&n);
    while(n--){
        scanf("%d %d %d",&N,&M,&R);
        V=N+M;
        E=R;
        for(i,0,R){
            scanf("%d %d %d",&x,&y,&d);
            es[i].u=x;
            es[i].v=y+N;
            es[i].cost=d;
        }
        int res=kruskal();
        printf("%d\n",(N+M)*10000-res);

    }
    //fclose(stdin);
    //fclose(stdout);
    return 0;
}

 

poj3723_Conscription

标签:turn   mount   font   ios   use   for   --   sed   logs   

原文地址:http://www.cnblogs.com/TWS-YIFEI/p/6359037.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!