码迷,mamicode.com
首页 > 其他好文 > 详细

TOJ-1324 Boastin' Red Socks

时间:2017-02-01 12:33:34      阅读:261      评论:0      收藏:0      [点我收藏+]

标签:return   into   str   nat   lang   drawer   any   tip   blog   

You have a drawer that is full of two kinds of socks: red and black. You know that there are at least 2 socks, and not more than 50000. However, you do not know how many there actually are, nor do you know how many are red, or how many are black. (Your mother does the laundry!)

You have noticed, though, that when you reach into the drawer each morning and choose two socks to wear (in pitch darkness, so you cannot distinguish red from black), the probability that you pick two red socks is exactly p/q, where 0 < q and 0 ≤ pq.

From this, can you determine how many socks of each colour are in your drawer? There may be multiple solutions - if so, pick the solution with the fewest total number of socks.

Input

Input consists of multiple problems, each on a separate line. Each problem consists of the integers p and q separated by a single space. Note that p and q will both fit into an unsigned long integer.

Input is terminated by a line consisting of two zeroes.

Output

For each problem, output a single line consisting of the number of red socks and the number of black socks in your drawer, separated by one space. If there is no solution to the problem, print "impossible".

Sample Input

1 2
6 8
12 2499550020
56 789
0 0

Sample Output

3 1
7 1
4 49992
impossible



Source: Waterloo Local Contest Jun. 19, 1999

设红色袜子数为r,总共为t,黑色袜子数即为t-r。由题意:

r(r-1) / t(t-1) = p/q。

#include <iostream>
#include <math.h>
using namespace std;
long long gcd(long long a,long long b){
    return b==0 ? a : gcd(b,a%b);
}
int main(){
    long long p,q,g,r,t,h,d; 
    while(cin>>p>>q,p,q){
        if(p == 0){
            cout<<0<<" "<<2<<endl;
            continue;
        }
        g = gcd(p,q);cout<<g<<endl;
        p /= g;
        q /= g;//让pq互质
        bool f = false;
        for(t=2;t<=50000;t++){//枚举总袜子数t 
            if(t*(t-1)%q==0){//可行的 t值 
                 h = t*(t-1)/q*p;
                 d = sqrt(4*h+1);//求根公式
                 if(d*d!=4*h+1) continue;
                 if((d+1)%2==0){
                     r=(d+1)/2;
                     cout<<r<<" "<<t-r<<endl;
                     f = true;
                     break;
                 }
            }
            
        }
        if(!f) cout<<"impossible"<<endl;
    }
    return 0;
}

奇怪的地方是,用unsigned long 得到WA,可能是涉及相乘位数不够吧。

 

TOJ-1324 Boastin' Red Socks

标签:return   into   str   nat   lang   drawer   any   tip   blog   

原文地址:http://www.cnblogs.com/shenchuguimo/p/6359891.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!