码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 4968 Improving the GPA

时间:2014-08-19 22:34:15      阅读:314      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   java   os   io   strong   


枚举。。。

Improving the GPA

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 158    Accepted Submission(s): 126


Problem Description
Xueba: Using the 4-Point Scale, my GPA is 4.0.

In fact, the AVERAGE SCORE of Xueba is calculated by the following formula:
AVERAGE SCORE = ∑(Wi * SCOREi) / ∑(Wi) 1<=i<=N

where SCOREi represents the scores of the ith course and Wi represents the credit of the corresponding course.

To simplify the problem, we assume that the credit of each course is 1. In this way, the AVERAGE SCORE is ∑(SCOREi) / N. In addition, SCOREi are all integers between 60 and 100, and we guarantee that ∑(SCOREi) can be divided by N.

In SYSU, the university usually uses the AVERAGE SCORE as the standard to represent the students’ level. However, when the students want to study further in foreign countries, other universities will use the 4-Point Scale to represent the students’ level. There are 2 ways of transforming each score to 4-Point Scale. Here is one of them. 
bubuko.com,布布扣


The student’s average GPA in the 4-Point Scale is calculated as follows:
GPA = ∑(GPAi) / N

So given one student’s AVERAGE SCORE and the number of the courses, there are many different possible values in the 4-Point Scale. Please calculate the minimum and maximum value of the GPA in the 4-Point Scale. 
 

Input
The input begins with a line containing an integer T (1 < T < 500), which denotes the number of test cases. The next T lines each contain two integers AVGSCORE, N (60 <= AVGSCORE <= 100, 1 <= N <= 10).
 

Output
For each test case, you should display the minimum and maximum value of the GPA in the 4-Point Scale in one line, accurate up to 4 decimal places. There is a space between two values.
 

Sample Input
4 75 1 75 2 75 3 75 10
 

Sample Output
3.0000 3.0000 2.7500 3.0000 2.6667 3.1667 2.4000 3.2000
Hint
In the third case, there are many possible ways to calculate the minimum value of the GPA in the 4-Point Scale. For example, Scores 78 74 73 GPA = (3.0 + 2.5 + 2.5) / 3 = 2.6667 Scores 79 78 68 GPA = (3.0 + 3.0 + 2.0) / 3 = 2.6667 Scores 84 74 67 GPA = (3.5 + 2.5 + 2.0) / 3 = 2.6667 Scores 100 64 61 GPA = (4.0 + 2.0 + 2.0) / 3 = 2.6667
 

Source
 



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int level[6][2]={{100,85},{84,80},{79,75},{74,70},{69,60},{59,0}};

int main()
{
    int T_T;
    scanf("%d",&T_T);
    while(T_T--)
    {
        int f,n;
        double mi=20.,mx=-20.;
        scanf("%d%d",&f,&n);
        for(int l1=0;l1<=n;l1++)
        {
            int res1=n-l1;
            for(int l2=0;l2<=res1;l2++)
            {
                int res2=n-l1-l2;
                for(int l3=0;l3<=res2;l3++)
                {
                    int res3=n-l1-l2-l3;
                    for(int l4=0;l4<=res3;l4++)
                    {
                        int l5=res3-l4;
                        int minsorce=level[0][1]*l1+level[1][1]*l2+level[2][1]*l3+
                        level[3][1]*l4+level[4][1]*l5;
                        int maxsorce=level[0][0]*l1+level[1][0]*l2+level[2][0]*l3+
                        level[3][0]*l4+level[4][0]*l5;
                        if(f*n<=maxsorce&&f*n>=minsorce)
                        {
                            mi=min(mi,(4.*l1+3.5*l2+3.*l3+2.5*l4+2.*l5)/n);
                            mx=max(mx,(4.*l1+3.5*l2+3.*l3+2.5*l4+2.*l5)/n);
                        }
                    }
                }
            }
        }
        printf("%.4lf %.4lf\n",mi,mx);
    }
    return 0;
}



HDOJ 4968 Improving the GPA,布布扣,bubuko.com

HDOJ 4968 Improving the GPA

标签:des   style   http   color   java   os   io   strong   

原文地址:http://blog.csdn.net/ck_boss/article/details/38687865

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!