码迷,mamicode.com
首页 > 其他好文 > 详细

Holding Bin-Laden Captive!(1.多重背包 2.母函数)

时间:2017-02-01 22:39:28      阅读:283      评论:0      收藏:0      [点我收藏+]

标签:hid   pos   eof   sed   raid   print   this   clu   logs   

Holding Bin-Laden Captive!

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 41 Accepted Submission(s): 29
 
Problem Description
We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China!
“Oh, God! How terrible! ”

技术分享


Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up!
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!
 
Input
Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.
 
Output

            Output the minimum positive value that one cannot pay with given coins, one line for one case.
 
Sample Input
1 1 3
0 0 0
 
Sample Output
4
 
Author
lcy
 
/*
题意:给你面值1,2,5的金币的个数,让你求出最小不能组成的金额

初步思路:暴力是不可取  1e12,以前做过一道丑数的题,这个题可以拿来参考一下

#错误:每个能凑成的数都是由前一个状态转移过来的
    根本行不通,那个是没有数量限制的......多重背包再来搞一下,总共三种物品每个取或者不取,没有覆盖的点就是不能凑出来的
    
#感悟:......我去,竟然多重背包爆过了

*/
#include<bits/stdc++.h>
using namespace std;
int num[4];
int dp[8010];//dp[i]表示i是否能凑出来
int cur=0;
int v[]={1,2,5};
void init(){
    memset(dp,0,sizeof dp);
}
int main(){
    //freopen("in.txt","r",stdin);
    while(scanf("%d%d%d",&num[0],&num[1],&num[2])!=EOF&&(num[0]+num[1]+num[2])){
        init();
        cur=num[0]+num[1]*2+num[2]*5;//总的钱数
        dp[0]=1;
        for(int i=0;i<3;i++){
            for(int j=0;j<num[i];j++){
                for(int k=cur;k>=v[i];k--){
                    dp[k]+=dp[k-v[i]];
                }
            }
        }
        int id=cur+1;
        for(int i=0;i<cur;i++){
            //cout<<dp[i]<<" ";
            if(!dp[i]){
                id=i;
                break;
            }
        }
        printf("%d\n",id);
        //cout<<endl;
    }
    return 0;
}

未完......待续

Holding Bin-Laden Captive!(1.多重背包 2.母函数)

标签:hid   pos   eof   sed   raid   print   this   clu   logs   

原文地址:http://www.cnblogs.com/wuwangchuxin0924/p/6360431.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!