码迷,mamicode.com
首页 > 其他好文 > 详细

Ignatius and the Princess I

时间:2017-02-05 21:29:42      阅读:251      评论:0      收藏:0      [点我收藏+]

标签:map   剪枝   ane   ems   ica   sam   优先队列   return   情况   

Ignatius and the Princess I

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 114 Accepted Submission(s): 71
 
Problem Description
The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166‘s castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a N*M two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166‘s room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:

1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1).
2.The array is marked with some characters and numbers. We define them like this:
. : The place where Ignatius can walk on.
X : The place is a trap, Ignatius should not walk on it.
n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.

Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.
 
Input
The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N*M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.
 
Output
For each test case, you should output "God please help our poor hero." if Ignatius can‘t reach the target position, or you should output "It takes n seconds to reach the target position, let me show you the way."(n is the minimum seconds), and tell our hero the whole path. Output a line contains "FINISH" after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.
 
Sample Input
5 6
.XX.1.
..X.2.
2...X.
...XX.
XXXXX.
5 6
.XX.1.
..X.2.
2...X.
...XX.
XXXXX1
5 6
.XX...
..XX1.
2...X.
...XX.
XXXXX.
 
Sample Output
It takes 13 seconds to reach the target position, let me show you the way.
1s:(0,0)->(1,0)
2s:(1,0)->(1,1)
3s:(1,1)->(2,1)
4s:(2,1)->(2,2)
5s:(2,2)->(2,3)
6s:(2,3)->(1,3)
7s:(1,3)->(1,4)
8s:FIGHT AT (1,4)
9s:FIGHT AT (1,4)
10s:(1,4)->(1,5)
11s:(1,5)->(2,5)
12s:(2,5)->(3,5)
13s:(3,5)->(4,5)
FINISH
It takes 14 seconds to reach the target position, let me show you the way.
1s:(0,0)->(1,0)
2s:(1,0)->(1,1)
3s:(1,1)->(2,1)
4s:(2,1)->(2,2)
5s:(2,2)->(2,3)
6s:(2,3)->(1,3)
7s:(1,3)->(1,4)
8s:FIGHT AT (1,4)
9s:FIGHT AT (1,4)
10s:(1,4)->(1,5)
11s:(1,5)->(2,5)
12s:(2,5)->(3,5)
13s:(3,5)->(4,5)
14s:FIGHT AT (4,5)
FINISH
God please help our poor hero.
FINISH
 
Author
Ignatius.L
 
/*
题意:很好理解,就是迷宫的搜索问题嘛,找出一条最短的从(0,0)到(n-1,m-1),遇到怪物还要花费相应的时间进行消灭才能通过。然后打印
    路径,输出最短的时间。
初步思路:先进行bfs加一个优先队列进行剪枝,找到最短时间之后,再打印路径。

#错误:用bfs加优先队列的时候遇到问题,并不能得到最优解,擦掉重写一发

#改进:果然是写残了,重写了一发就可以了,剩下的就是打印路径的问题了,用一个path数组记录路径,然后递归进行打印路径

#重点:又交了一发wa了,看了一下discuss,漏了一种情况,起点也是可能有守卫的

#错误:不知道为啥,加上这种情况还是wa

#改进:重新找到错误了,在处理最后一步的时候,路径记录的不准确
        这组数据很关键
        3 3
        ...
        .X.
        ..8
        如果有两条路的话就不行了,所以递归的时候要从后往前递归
*/
#include<bits/stdc++.h>
using namespace std;
int n,m;
char mapn[110][110];
int vis[110][110];
int path[110][110];//用于记录路径
int Time,cur;
int dir[4][2]={1,0,-1,0,0,1,0,-1};
struct node{
    int x,y;//位置
    int times;//用到的时间
    node(){}
    node(int a,int b,int c){
        x=a;
        y=b;
        times=c;
    }
    bool operator <(const node& other)const{
        return times>other.times;
    }
};
bool ok(int x,int y){
    if(x<0||x>=n||y<0||y>=m||mapn[x][y]==X||vis[x][y])
        return true;
    return false;
}
int bfs(){
    memset(vis,0,sizeof vis);
    priority_queue<node>q;
    if(mapn[0][0]==.)
        q.push(node(0,0,0));
    else if(mapn[0][0]>=0&&mapn[0][0]<=9){
        q.push(node(0,0,mapn[0][0]-0));
        Time+=mapn[0][0]-0;
    }
    vis[0][0]=1;
    while(!q.empty()){
        node fa=q.top();
        q.pop();
        //cout<<fa.x<<" "<<fa.y<<endl;
        if(fa.x==n-1&&fa.y==m-1)
            return fa.times;
        for(int i=0;i<4;i++){
            int fx=fa.x+dir[i][0];
            int fy=fa.y+dir[i][1];
            if(ok(fx,fy)) continue;
            //printf("(%d,%d)->(%d,%d)\n",fa.x,fa.y,fx,fy);
            path[fx][fy]=i;//走的是第几步
            //cout<<fa.x<<" "<<fa.y<<" "<<path[fa.x][fa.y]<<endl;
            vis[fx][fy]=1;
            if(mapn[fx][fy]==.){
                q.push(node(fx,fy,fa.times+1));
            }else{
                q.push(node(fx,fy,fa.times+(mapn[fx][fy]-0)+1));
                // cout<<fx<<" "<<fy<<" 这地方有守卫"<<endl;
            }
        }
    }
    return -1;
}
void print(int x,int y){
    if(path[x][y]==-1){
        return;
    }
    int next_x=x-dir[path[x][y]][0];
    int next_y=y-dir[path[x][y]][1];
    print(next_x,next_y);
    printf("%ds:(%d,%d)->(%d,%d)\n",Time++,next_x,next_y,x,y);
    if(mapn[x][y]>=0&&mapn[x][y]<=9){
        int res=mapn[x][y]-0;
        while(res--){
            printf("%ds:FIGHT AT (%d,%d)\n",Time++,x,y);
        }
    }
}
void init(){
    Time=1;
    memset(path,-1,sizeof path);
}
int main(){
    // freopen("in.txt","r",stdin);
    while(scanf("%d%d",&n,&m)!=EOF){
        // cout<<n<<" "<<m<<endl; 
        init();
        for(int i=0;i<n;i++){
            scanf("%s",&mapn[i]);
            // cout<<mapn[i]<<endl;
        }//输入地图
        cur=bfs();
        if(cur==-1) puts("God please help our poor hero.");
        else{
            printf("It takes %d seconds to reach the target position, let me show you the way.\n",cur);
            if(Time!=1){
                for(int i=1;i<Time;i++){
                    printf("%ds:FIGHT AT (0,0)\n",i);
                }
            }
            print(n-1,m-1);
        }
        puts("FINISH");
    }
    return 0;
}

 

Ignatius and the Princess I

标签:map   剪枝   ane   ems   ica   sam   优先队列   return   情况   

原文地址:http://www.cnblogs.com/wuwangchuxin0924/p/6368577.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!