码迷,mamicode.com
首页 > 其他好文 > 详细

poj - 3080-Blue Jeans

时间:2017-02-08 23:13:21      阅读:221      评论:0      收藏:0      [点我收藏+]

标签:str   from   bsp   mem   repr   status   des   plm   lan   

 

poj - 3080-Blue Jeans

                                            Blue Jeans

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 17434   Accepted: 7728

Description

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated. 

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers. 

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC. 

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:
  • A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
  • m lines each containing a single base sequence consisting of 60 bases.

Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.

Sample Input

3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output

no significant commonalities
AGATAC
CATCATCAT

Source

 

16558378 sunshinestyle 3080 Accepted 700K 16MS G++ 1245B 2017-02-08 22:06:52

 

 

题解:

初级题目, 采用暴力即可。求出两两的最长连续子串,逐个匹配。 

 

 

//p-3080  

#include <iostream> 
#include <cstdio> 
#include <cstdlib> 
#include <cstring> 
using namespace std; 
const int MAXN = 65; 
const int MAXM = 11; 

int dp[MAXN][MAXN];  
char data[MAXM][MAXN], LCS[MAXN], comp[MAXN]; 

int function(int idx){
	memset(dp, 0, sizeof(dp));
	int max_len = 0, pt = -1;   
	for(int i=1; i<=60; ++i){
		for(int j=1; j<=strlen(comp+1); ++j){
			if(data[idx][i] == comp[j]){
				dp[i][j] = dp[i-1][j-1] + 1; 
				if(dp[i][j] > max_len){
					max_len = dp[i][j]; 
					pt = j; 
				} else if(dp[i][j] == max_len){
					if(comp[j-max_len+1] < comp[pt-max_len+1]){
						pt = j; 
					}
				}
			}
		}
	}
	if(max_len >= 3){
		for(int i=1; i<=max_len; ++i){
			LCS[i] = comp[pt-max_len+i]; 
		}
		LCS[max_len+1] = ‘\0‘; 
	}
	return max_len; 
}

int main(){
	freopen("in.txt", "r", stdin); 

	int test_num, m; 
	scanf("%d", &test_num); 
	while(test_num--){
		scanf("%d", &m); 
		scanf("%s", comp+1); 
		for(int i=0; i<m-1; ++i){
			scanf("%s", data[i]+1); 
		}
		int idx = 0, flag = 1; 
		while(idx<(m-1)){
			if(function(idx) < 3){
				flag = 0; 
				break; 
			}
			strcpy(comp+1, LCS+1); 
			idx++; 
		}
		if(flag == 0 || strlen(LCS+1) < 3){
			printf("no significant commonalities\n");
		}else{
			printf("%s\n", LCS+1 );
		}
	}
	return 0; 
}

  

 

poj - 3080-Blue Jeans

标签:str   from   bsp   mem   repr   status   des   plm   lan   

原文地址:http://www.cnblogs.com/zhang-yd/p/6380085.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!