码迷,mamicode.com
首页 > 其他好文 > 详细

UVA Phone List (字典树)(查询是否有前缀或自身是其他的前缀)

时间:2017-02-09 23:04:22      阅读:272      评论:0      收藏:0      [点我收藏+]

标签:mit   mos   key   自身   its   des   can   esc   for   

Phone List
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 16341   Accepted: 5228

Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let‘s say the phone catalogue listed these numbers:

  • Emergency 911
  • Alice 97 625 999
  • Bob 91 12 54 26

In this case, it‘s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob‘s phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

Source

【分析】字典树
 
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <time.h>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#define met(a,b) memset(a,b,sizeof a)
#define pb push_back
#define lson(x) ((x<<1))
#define rson(x) ((x<<1)+1)
using namespace std;
typedef long long ll;
const int N=10;
const int M=1e6+10;
typedef struct TrieNode {
    int endflag;
    struct TrieNode *next[N];
} TrieNode;

TrieNode Memory[M];
int allocp=0;
bool flag;

void InitTrieRoot(TrieNode **pRoot) {
    *pRoot=NULL;
}

TrieNode *CreateTrieNode() {
    int i;
    TrieNode *p;

    p=&Memory[allocp++];
    p->endflag=0;
    for(i=0; i<N; i++) {
        p->next[i]=NULL;
    }
    return p;
}

void InsertTrie(TrieNode **pRoot,char *s) {
    int i,k;
    TrieNode *p;

    if(!(p=*pRoot))
        p=*pRoot=CreateTrieNode();
    i=0;
    while(s[i]) {
        k=s[i++]-0;
        if(p->next[k]) {
            if(p->next[k]->endflag==1||s[i]==\0) {
                flag=false;
                return;
            }
        } else p->next[k]=CreateTrieNode();
        p=p->next[k];
    }
    p->endflag=1;
}

int main() {
    char str[50];
    TrieNode *Root=NULL;
    int T;
    scanf("%d",&T);
    int n;
    while(T--) {
        flag=true;
        allocp=0;
        scanf("%d",&n);
        InitTrieRoot(&Root);
        for(int i=0; i<n; i++) {
            //gets(str);//用这个会超时
            scanf("%s",&str);
            if(flag) InsertTrie(&Root,str);
        }
        if(flag) printf("YES\n");
        else printf("NO\n");
    }


    return 0;
}

 

UVA Phone List (字典树)(查询是否有前缀或自身是其他的前缀)

标签:mit   mos   key   自身   its   des   can   esc   for   

原文地址:http://www.cnblogs.com/jianrenfang/p/6384036.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!