码迷,mamicode.com
首页 > 其他好文 > 详细

poj3370Halloween treats(鸽笼原理)

时间:2014-08-20 12:35:22      阅读:309      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   os   io   strong   

题目链接:

思路:

这个是鸽笼原理的题目。。。看了一下这个原理,对此的理解是分为三点。。
c代表人的数目,n代表家庭的数目。。
【1】首先要求前缀和,然后对此取余,首先如果出现余数为0的情况,那么说明前n项就已经满足了条件,那么这就是其中的一组可行解。。。
【2】但是如果没有出现0呢??那么就看同余了。。如果在两个点处出现同余,说明什么??说明从上一个出现同余的后一个数到这个数的和为c的倍数,那么就得到了一组可行解。。
【3】题目说没有情况则输出“no sweetws”,但是说明情况下出现呢???只有当不出现【1】【2】的情况,当说明时候不出现呢???那么就是n<c的时候可能会出现不可能的情况,因为可能不会出现同余的情况,但是如果n>=c的话肯定会出现两个点处出现同余。。
那么这个问题就解决了。。。

题目:
Halloween treats
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 6638   Accepted: 2451   Special Judge

Description

Every year there is the same problem at Halloween: Each neighbour is only willing to give a certain total number of sweets on that day, no matter how many children call on him, so it may happen that a child will get nothing if it is too late. To avoid conflicts, the children have decided they will put all sweets together and then divide them evenly among themselves. From last year‘s experience of Halloween they know how many sweets they get from each neighbour. Since they care more about justice than about the number of sweets they get, they want to select a subset of the neighbours to visit, so that in sharing every child receives the same number of sweets. They will not be satisfied if they have any sweets left which cannot be divided.

Your job is to help the children and present a solution.

Input

The input contains several test cases.
The first line of each test case contains two integers c and n (1 ≤ c ≤ n ≤ 100000), the number of children and the number of neighbours, respectively. The next line contains n space separated integers a1 , ... , an (1 ≤ ai ≤ 100000 ), where ai represents the number of sweets the children get if they visit neighbour i.

The last test case is followed by two zeros.

Output

For each test case output one line with the indices of the neighbours the children should select (here, index i corresponds to neighbour i who gives a total number of ai sweets). If there is no solution where each child gets at least one sweet print "no sweets" instead. Note that if there are several solutions where each child gets at least one sweet, you may print any of them.

Sample Input

4 5
1 2 3 7 5
3 6
7 11 2 5 13 17
0 0

Sample Output

3 5
2 3 4

Source


代码:

#include<cstdio>
#include<cstring>
const int maxn=100000+10;

int a[maxn],mod[maxn];
int c,n;

int main()
{
    __int64 sum;
    while(~scanf("%d%d",&c,&n))
    {
        if(c==0&&n==0)  return 0;
        sum=0;
        for(int i=1;i<=n;i++)
           scanf("%d",&a[i]);
        for(int i=0;i<c;i++)
            mod[i]=-1;
        for(int i=1;i<=n;i++)
        {
            sum=(sum+a[i])%c;
            if(sum==0)
            {
                for(int j=1;j<i;j++)
                    printf("%d ",j);
                printf("%d\n",i);
                break;
            }
            if(mod[sum]!=-1)
            {
                for(int j=mod[sum]+1;j<i;j++)
                    printf("%d ",j);
                printf("%d\n",i);
                break;
            }
            mod[sum]=i;
        }
    }
    return 0;
}




poj3370Halloween treats(鸽笼原理),布布扣,bubuko.com

poj3370Halloween treats(鸽笼原理)

标签:des   style   blog   http   color   os   io   strong   

原文地址:http://blog.csdn.net/u014303647/article/details/38703419

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!