码迷,mamicode.com
首页 > 其他好文 > 详细

最大子矩阵 hdu1081

时间:2017-02-10 21:46:21      阅读:249      评论:0      收藏:0      [点我收藏+]

标签:turn   sizeof   its   com   onclick   clu   sed   space   isp   

To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12471    Accepted Submission(s): 5985


Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

 

Output
Output the sum of the maximal sub-rectangle.
 

 

Sample Input
4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
 

 

Sample Output
15
 

 

技术分享
#include <iostream>
#include <algorithm>
#include <vector>
#include<string.h>
using namespace std;
int a[55][55];
int main()
{
    int n,m;
    cin>>n>>m;
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<m;j++)
        {
            cin>>a[i][j];
            a[i][j]+=a[i-1][j];
        }
    }
    int dp[55];
    memset(dp,0,sizeof(dp));
    int ans=-0x3fffffff;
    for(int i=0;i<n-1;i++)
    {
        for(int j=i+1;j<n;j++)
        {
            for(int k=1;k<=m;k++)
            {
              dp[k]=a[j][k-1]-a[i][k-1];
              dp[k]=dp[k]+dp[k-1];

              if(dp[k]>ans) ans=dp[k];
              if(dp[k]<0) dp[k]=0;
            }
        }
    }
    printf("%d\n",ans);
    return 0;
}
View Code

令a[i][k]保存第k列,前i行的和。这样将矩阵通过a[j][k]-a[i][k]压缩成一维,然后求最大字串和。。

 

最大子矩阵 hdu1081

标签:turn   sizeof   its   com   onclick   clu   sed   space   isp   

原文地址:http://www.cnblogs.com/superxuezhazha/p/6387756.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!