码迷,mamicode.com
首页 > 其他好文 > 详细

poj2356Find a multiple(鸽笼原理)

时间:2014-08-20 16:21:22      阅读:294      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   os   io   strong   

题目链接:

思路:

详见传送门

题目:

Find a multiple
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6015   Accepted: 2609   Special Judge

Description

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set.

Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order. 

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

Sample Input

5
1
2
3
4
1

Sample Output

2
2
3

Source


代码:

#include<cstdio>
#include<cstring>
const int maxn=10000+10;

int a[maxn],mod[maxn],n;

int main()
{
    __int64 sum;
    while(~scanf("%d",&n))
    {
        sum=0;
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        for(int i=0;i<n;i++)
            mod[i]=-1;
        for(int i=1;i<=n;i++)
        {
            sum=(sum+a[i])%n;
            if(sum==0)
            {
                printf("%d\n",i);
                for(int j=1;j<=i;j++)
                   printf("%d\n",a[j]);
                break;
            }
            if(mod[sum]!=-1)
            {
                printf("%d\n",i-mod[sum]);
                for(int j=mod[sum]+1;j<=i;j++)
                    printf("%d\n",a[j]);
                break;
            }
            mod[sum]=i;
        }
    }
    return 0;
}



poj2356Find a multiple(鸽笼原理),布布扣,bubuko.com

poj2356Find a multiple(鸽笼原理)

标签:des   style   blog   http   color   os   io   strong   

原文地址:http://blog.csdn.net/u014303647/article/details/38707593

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!