码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ-1015 Safecracker 【DFS】

时间:2017-02-16 22:42:43      阅读:192      评论:0      收藏:0      [点我收藏+]

标签:down   because   contains   mat   mit   dig   use   for   bottom   

Safecracker

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13669    Accepted Submission(s): 7150


Problem Description
=== Op tech briefing, 2002/11/02 06:42 CST === 
"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein‘s secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary." 

v - w^2 + x^3 - y^4 + z^5 = target 

"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn‘t exist then." 

=== Op tech directive, computer division, 2002/11/02 12:30 CST === 

"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or ‘no solution‘ if there is no correct combination. Use the exact format shown below."
 

 

Sample Input
1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END
 
Sample Output
LKEBA
YOXUZ
GHOST
no solution
 
代码:
#include <iostream>
#include <cstdlib>
#include <algorithm>
#include <cstdio>
using namespace std;
int len, tar, res[6];
char s[13];
bool vis[13],flag;
bool cmp(char a, char b) {
    return a > b;
}
int pow(int n, int times) {
    int res = n;
    times--;
    while (times--) {
        res *= n;
    }
    return res;
}
void dfs(int n) {
    if (n == 5) {
        int sum = res[0] - pow(res[1], 2) + pow(res[2], 3) - pow(res[3], 4) + pow(res[4], 5);
        if (sum == tar)
            flag = true;
        return;
    }
    for (int i = 0; i < len; i++) {
        if (!vis[i] && !flag) {
            res[n] = s[i] - A + 1;
            vis[i] = true;
            dfs(n + 1);
            vis[i] = false;
        }
    }
    return;
}
int main(void)
{
    ios::sync_with_stdio(false);
    cin.tie(false);

    while (cin >> tar >> s) {
        if (tar == 0 && strcmp(s, "END") == 0) 
            break;
        flag = false;
        len = strlen(s);
        memset(vis, false, sizeof(vis));
        sort(s, s + len, cmp);
        dfs(0);
        if (flag) {
            for (int i = 0; i < 5; i++)
                printf("%c", res[i] + A - 1);
            cout << endl;
        }
        else
            cout << "no solution" << \n;
    }
    return 0;
}

HDOJ-1015 Safecracker 【DFS】

标签:down   because   contains   mat   mit   dig   use   for   bottom   

原文地址:http://www.cnblogs.com/ray-coding-in-rays/p/6407140.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!