码迷,mamicode.com
首页 > 其他好文 > 详细

poj3623 Best Cow Line, Gold(贪心)

时间:2014-08-20 16:23:02      阅读:236      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   os   io   strong   

题目链接:

思路:

选取字典序最小的串,那么值得考虑的是当两端出现相等时,继续比较,直到出现不同的结果。。

题目:

Best Cow Line, Gold
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 4574   Accepted: 1682

Description

FJ is about to take his N (1 ≤ N ≤ 30,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows‘ names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he‘s finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial (‘A‘..‘Z‘) of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows (‘A‘..‘Z‘) in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

Source


bubuko.com,布布扣
bubuko.com,布布扣
代码:
#include<cstdio>
#include<iostream>

const int maxn=30000+10;

char s[maxn];
int n;

void Greedy()
{
    int a=0,b=n-1,cal=0;
    bool left;
    while(a<=b)
    {
      for(int i=0;a+i<=b;i++)
       {
          if(s[a+i]<s[b-i])
           {
              left=true;
              break;
           }
          else if(s[a+i]>s[b-i])
           {
             left=false;
             break;
           }
       }
       if(left)  printf("%c",s[a++]);
       else printf("%c",s[b--]);
       cal++;
       if(cal%80==0)  printf("\n");
    }
    printf("\n");
}

int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++)
            scanf("%s",&s[i]);
        Greedy();
    }
    return 0;
}




poj3623 Best Cow Line, Gold(贪心),布布扣,bubuko.com

poj3623 Best Cow Line, Gold(贪心)

标签:des   style   blog   http   color   os   io   strong   

原文地址:http://blog.csdn.net/u014303647/article/details/38707413

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!