码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 4965(矩阵乘法 )

时间:2014-08-20 16:28:02      阅读:228      评论:0      收藏:0      [点我收藏+]

标签:acm   矩阵连乘   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4965

Fast Matrix Calculation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 455    Accepted Submission(s): 241


Problem Description
One day, Alice and Bob felt bored again, Bob knows Alice is a girl who loves math and is just learning something about matrix, so he decided to make a crazy problem for her.

Bob has a six-faced dice which has numbers 0, 1, 2, 3, 4 and 5 on each face. At first, he will choose a number N (4 <= N <= 1000), and for N times, he keeps throwing his dice for K times (2 <=K <= 6) and writes down its number on the top face to make an N*K matrix A, in which each element is not less than 0 and not greater than 5. Then he does similar thing again with a bit difference: he keeps throwing his dice for N times and each time repeat it for K times to write down a K*N matrix B, in which each element is not less than 0 and not greater than 5. With the two matrix A and B formed, Alice’s task is to perform the following 4-step calculation.

Step 1: Calculate a new N*N matrix C = A*B.
Step 2: Calculate M = C^(N*N).
Step 3: For each element x in M, calculate x % 6. All the remainders form a new matrix M’.
Step 4: Calculate the sum of all the elements in M’.

Bob just made this problem for kidding but he sees Alice taking it serious, so he also wonders what the answer is. And then Bob turn to you for help because he is not good at math.
 

Input
The input contains several test cases. Each test case starts with two integer N and K, indicating the numbers N and K described above. Then N lines follow, and each line has K integers between 0 and 5, representing matrix A. Then K lines follow, and each line has N integers between 0 and 5, representing matrix B.

The end of input is indicated by N = K = 0.
 

Output
For each case, output the sum of all the elements in M’ in a line.
 

Sample Input
4 2 5 5 4 4 5 4 0 0 4 2 5 5 1 3 1 5 6 3 1 2 3 0 3 0 2 3 4 4 3 2 2 5 5 0 5 0 3 4 5 1 1 0 5 3 2 3 3 2 3 1 5 4 5 2 0 0
 

Sample Output
14 56
 
题意明确:(1)计算(A*B)^(n*n),并且每个元素对6取余,最后求矩阵中所有元素之和

                      (2)如果先算A*B,那么会使一个n*n的矩阵,n最多可达1000;那么算起来会很麻烦,而且还存在一个问题:如果在一个结构体中开一个数组当矩阵,那么大小不能太大,不然运行不了。开到f[800][800]都运行不了,更别说1000*1000;

                       (3)所以转化一下,将(A*B)^(n*n)展开,A*(B*A)*(B*A)*(B*A)*(B*A)*B不难发现,要求的就是 A*(B*A)^(n*n-1)*B;

                      先对中间部分用矩阵快速幂,然后再暴力将左右两个矩阵乘起来即可;

                            

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <cstdio>
#include <algorithm>
#include <cmath>
const int kmaxn=6;  //题目中说了k最多取到6
const int maxn=1000; // n最多取到1000
const int mod=6;     //对6取余
using namespace std;
int b[kmaxn][maxn]; //存储一个6*1000的矩阵
int a[maxn][kmaxn]; //存储一个1000*6的矩阵
int c[kmaxn][maxn]; //存储一个6*1000的矩阵
int d[maxn][maxn];  //存储一个1000*1000的矩阵
struct matrix      
{
 int f[kmaxn][kmaxn]; //6*6的矩阵
};
matrix mul(matrix a,matrix b) //矩阵乘法 6*6
{
  matrix c;
  memset(c.f,0,sizeof(c.f));
  for(int i=0;i<kmaxn;i++)
   for(int j=0;j<kmaxn;j++)
    for(int k=0;k<kmaxn;k++)
     {
      c.f[i][j]+=(a.f[i][k]*b.f[k][j])%mod;
      c.f[i][j]%=mod;
     }
  return c;
}
matrix quick(matrix a,int k) //矩阵快速幂 6*6
{
  matrix I;
  memset(I.f,0,sizeof(I.f));
  for(int i=0;i<kmaxn;i++)
    I.f[i][i]=1;
  while(k)
  {
    if(k&1)
        I=mul(I,a);
    k=k/2;
    a=mul(a,a);
  }
  return I;
}
void Init_input(int n,int k)
{
 for(int i=0;i<n;i++)
 for(int j=0;j<k;j++)
  scanf("%d",&a[i][j]);
   
 for(int i=0;i<k;i++)
 for(int j=0;j<n;j++)
  scanf("%d",&b[i][j]);
}
int main()
{
 int n,k;
 while(cin>>n>>k)
 {
   if(n==0&&k==0)break;
   Init_input(n,k);
   
   matrix six;
   memset(six.f,0,sizeof(six.f));
   for(int i=0;i<k;i++)
    for(int j=0;j<k;j++)
     for(int l=0;l<n;l++)
     {
      six.f[i][j]+=b[i][l]*a[l][j]; // B*A
     }
   six=quick(six,n*n-1);// 计算(B*A)^(n*n-1)
   
  //将上一步计算的结果与最后一个B相乘
   memset(c,0,sizeof(c)); 
   for(int i=0;i<k;i++)
    for(int j=0;j<n;j++)
     for(int l=0;l<k;l++)
     {
      c[i][j]+=(six.f[i][l]*b[l][j])%mod; 
      c[i][j]%=mod;
     }
   //将上一步计算的结果与第一个A相乘  
   memset(d,0,sizeof(d));
   for(int i=0;i<n;i++)
    for(int j=0;j<n;j++)
     for(int l=0;l<k;l++)
     {
      d[i][j]+=(a[i][l]*c[l][j])%mod;
      d[i][j]%=mod;
     }
  //END 矩阵乘法
   int cnt=0;
   for(int i=0;i<n;i++)
    for(int j=0;j<n;j++)
      cnt+=d[i][j];
   cout<<cnt<<endl;
 }
 return 0;
}

hdu 4965(矩阵乘法 ),布布扣,bubuko.com

hdu 4965(矩阵乘法 )

标签:acm   矩阵连乘   

原文地址:http://blog.csdn.net/liusuangeng/article/details/38706425

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!