码迷,mamicode.com
首页 > 其他好文 > 详细

HDU4961:Boring Sum

时间:2014-08-20 16:34:02      阅读:184      评论:0      收藏:0      [点我收藏+]

标签:hdu

Problem Description
Number theory is interesting, while this problem is boring.

Here is the problem. Given an integer sequence a1, a2, …, an, let S(i) = {j|1<=j<i, and aj is a multiple of ai}. If S(i) is not empty, let f(i) be the maximum integer in S(i); otherwise, f(i) = i. Now we define bi as af(i). Similarly, let T(i) = {j|i<j<=n, and aj is a multiple of ai}. If T(i) is not empty, let g(i) be the minimum integer in T(i); otherwise, g(i) = i. Now we define ci as ag(i). The boring sum of this sequence is defined as b1 * c1 + b2 * c2 + … + bn * cn.

Given an integer sequence, your task is to calculate its boring sum.
 

Input
The input contains multiple test cases.

Each case consists of two lines. The first line contains an integer n (1<=n<=100000). The second line contains n integers a1, a2, …, an (1<= ai<=100000).

The input is terminated by n = 0.
 

Output
Output the answer in a line.
 

Sample Input
5 1 4 2 3 9 0
 

Sample Output
136
Hint
In the sample, b1=1, c1=4, b2=4, c2=4, b3=4, c3=2, b4=3, c4=9, b5=9, c5=9, so b1 * c1 + b2 * c2 + … + b5 * c5 = 136.
 

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;
#define up(i,x,y) for(i=x;i<=y;i++)
#define down(i,x,y) for(i=x;i>=y;i--)
#define mem(a,b) memset(a,b,sizeof(a))
#define w(x) while(x)
#define l 100005
#define ll __int64
#define s(a) scanf("%I64d",&a)
ll vis[l],a[l],b[l],c[l],n,i,j,ans;

int main()
{
    w((s(n),n))
    {
        up(i,1,n)
        s(a[i]);
        mem(vis,0);
        up(i,1,n)
        {
            if(vis[a[i]])
                b[i]=a[vis[a[i]]];
            else
                b[i]=a[i];
            up(j,1,sqrt(a[i]*1.0)+1)
            {
                if(a[i]%j==0)
                    vis[j]=vis[a[i]/j]=i;
            }
        }
        mem(vis,0);
        down(i,n,1)
        {
            if(vis[a[i]])
                c[i]=a[vis[a[i]]];
            else
                c[i]=a[i];
            up(j,1,sqrt(a[i]*1.0)+1)
            {
                if(a[i]%j==0)
                    vis[j]=vis[a[i]/j]=i;
            }
        }
        ans=0;
        up(i,1,n)
        ans+=b[i]*c[i];
        printf("%I64d\n",ans);
    }

    return 0;
}



HDU4961:Boring Sum,布布扣,bubuko.com

HDU4961:Boring Sum

标签:hdu

原文地址:http://blog.csdn.net/libin56842/article/details/38705729

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!