码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1711 KMP(模板题)

时间:2017-02-17 20:00:08      阅读:173      评论:0      收藏:0      [点我收藏+]

标签:log   mem   ica   out   make   cep   [1]   void   exists   

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 24587    Accepted Submission(s): 10436


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

 

Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
 

 

Sample Output
6
-1
 

 

Source

 题意:

给出T和P求p出现的位置

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=1000006;
const int maxm=10004;
int p[maxm],t[maxn];
int f[maxm],n,m;
void getfail(int* p,int* f){
    f[0]=0;f[1]=0;
    for(int i=1;i<m;i++){
        int j=f[i];
        while(j&&p[i]!=p[j]) j=f[j];
        f[i+1]=(p[i]==p[j]?j+1:0);
    }
}
int find(int* t,int* p,int* f){
    getfail(p,f);
    int j=0;
    for(int i=0;i<n;i++){
        while(j&&p[j]!=t[i]) j=f[j];
        if(p[j]==t[i]) j++;
        if(j==m) return i-m+1+1;//下标从0开始
    }
    return -1;
}
int main()
{
    int cas;
    scanf("%d",&cas);
    while(cas--){
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++) scanf("%d",&t[i]);
        for(int i=0;i<m;i++) scanf("%d",&p[i]);
        int ans=find(t,p,f);
        printf("%d\n",ans);
    }
    return 0;
}

 

HDU1711 KMP(模板题)

标签:log   mem   ica   out   make   cep   [1]   void   exists   

原文地址:http://www.cnblogs.com/--ZHIYUAN/p/6411227.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!