码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1498 50 years, 50 colors 最小点覆盖

时间:2017-02-18 13:32:43      阅读:203      评论:0      收藏:0      [点我收藏+]

标签:range   logs   mat   panel   acm   mit   大学生   color   竞赛   

50 years, 50 colors

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)



Problem Description
On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it‘s so nice, isn‘t it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named "crashing color balloons".

There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What‘s more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons.

Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.

技术分享
 

 

Input
There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0.
 

 

Output
For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print "-1".
 

 

Sample Input
1 1 1 2 1 1 1 1 2 2 1 1 2 2 2 5 4 1 2 3 4 5 2 3 4 5 1 3 4 5 1 2 4 5 1 2 3 5 1 2 3 4 3 3 50 50 50 50 50 50 50 50 50 0 0
 

 

Sample Output
-1 1 2 1 2 3 4 5 -1
 

 

Author
8600
 

 

Source
枚举每个点,建模,套板子;
#include<bits/stdc++.h>
using namespace std;
#define ll long long
#define pi (4*atan(1.0))
#define eps 1e-14
#define bug(x) cout<<"bug"<<x<<" "<<endl;
const int N=1e2+10,M=1e6+10,inf=2e9+10,mod=1e9+7;
const ll INF=1e18+10;
int n,m,q;
int a[N][N];
int mp[N][N];
int linker[N];
bool used[N];
bool dfs(int a)
{
    for(int i=0;i<n;i++)
      if(mp[a][i]&&!used[i])
      {
          used[i]=true;
          if(linker[i]==-1||dfs(linker[i]))
          {
              linker[i]=a;
              return true;
          }
      }
      return false;
}
int hungary()
{
    int result=0;
    memset(linker,-1,sizeof(linker));
    for(int i=0;i<n;i++)
    {
        memset(used,0,sizeof(used));
        if(dfs(i))  result++;
    }
    return result;
}
int slove(int f,int x)
{
    int cnt=0;
    memset(mp,0,sizeof(mp));
    for(int i=1;i<=f;i++)
    {
        for(int j=1;j<=f;j++)
        {
            if(a[i][j]==x)
            {
                cnt++;
                mp[i-1][j-1]=1;
            }
        }
    }
    if(cnt<=q)return 1;
    int kill=hungary();
    if(kill<=q)return 1;
    return 0;
}
int flag[100];
vector<int>ans;
int main()
{
    while(~scanf("%d%d",&n,&q))
    {
        if(n==0&&q==0)break;
        ans.clear();
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            scanf("%d",&a[i][j]);
        }
        for(int i=1;i<=50;i++)
        {
            if(!slove(n,i))
                ans.push_back(i);
        }
        if(ans.size()==0)
            printf("-1\n");
        else
        {
            printf("%d",ans[0]);
            for(int i=1;i<ans.size();i++)
            printf(" %d",ans[i]);
            printf("\n");
        }
    }
    return 0;
}

 

hdu 1498 50 years, 50 colors 最小点覆盖

标签:range   logs   mat   panel   acm   mit   大学生   color   竞赛   

原文地址:http://www.cnblogs.com/jhz033/p/6412940.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!