码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 3949: XOR

时间:2017-02-18 16:45:58      阅读:214      评论:0      收藏:0      [点我收藏+]

标签:algorithm   each   存在   cst   答案   stc   gauss   void   cte   

XOR

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2587    Accepted Submission(s): 877


Problem Description
XOR is a kind of bit operator, we define that as follow: for two binary base number A and B, let C=A XOR B, then for each bit of C, we can get its value by check the digit of corresponding position in A and B. And for each digit, 1 XOR 1 = 0, 1 XOR 0 = 1, 0 XOR 1 = 1, 0 XOR 0 = 0. And we simply write this operator as ^, like 3 ^ 1 = 2,4 ^ 3 = 7. XOR is an amazing operator and this is a question about XOR. We can choose several numbers and do XOR operatorion to them one by one, then we get another number. For example, if we choose 2,3 and 4, we can get 2^3^4=5. Now, you are given N numbers, and you can choose some of them(even a single number) to do XOR on them, and you can get many different numbers. Now I want you tell me which number is the K-th smallest number among them.
 

 

Input
First line of the input is a single integer T(T<=30), indicates there are T test cases.
For each test case, the first line is an integer N(1<=N<=10000), the number of numbers below. The second line contains N integers (each number is between 1 and 10^18). The third line is a number Q(1<=Q<=10000), the number of queries. The fourth line contains Q numbers(each number is between 1 and 10^18) K1,K2,......KQ.
 

 

Output
For each test case,first output Case #C: in a single line,C means the number of the test case which is from 1 to T. Then for each query, you should output a single line contains the Ki-th smallest number in them, if there are less than Ki different numbers, output -1.
 

 

Sample Input
2 2 1 2 4 1 2 3 4 3 1 2 3 5 1 2 3 4 5
 

 

Sample Output
Case #1: 1 2 3 -1 Case #2: 0 1 2 3 -1
Hint
If you choose a single number, the result you get is the number you choose. Using long long instead of int because of the result may exceed 2^31-1.
 

 

Author
elfness
 

 

Source
 

 

Recommend
xubiao   |   We have carefully selected several similar problems for you:  3946 3947 3945 3944 3950 

分析:

先求出线性基,然后把k二进制分解,如果第x位是1,就把答案xor上第i大的线性基...注意判断异或空间中是否存在0...

代码:

#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
//by NeighThorn
#define int long long
using namespace std;

const int maxn=10000+5;

int n,m,ans,cas,cnt,a[maxn];

inline void xor_gauss(void){
	cnt=0;
	for(int i=1;i<=n;i++){
		for(int j=n;j>i;j--)
			if(a[i]<a[j])
				swap(a[i],a[j]);
		if(a[i])
			cnt++;
		else
			break;
		for(int j=62;~j;j--)
			if((a[i]>>j)&1){
				for(int k=1;k<=n;k++)
					if(k!=i&&a[k]&&(a[k]>>j)&1)
						a[k]^=a[i];
				break;
			}
	}
}

signed main(void){
	scanf("%lld",&cas);int t=0;
	while(cas--){
		scanf("%lld",&n);
		printf("Case #%lld:\n",++t);
		for(int i=1;i<=n;i++)
			scanf("%lld",&a[i]);
		xor_gauss();
		scanf("%lld",&m);
		for(int i=1,k;i<=m;i++){
			scanf("%lld",&k);
			if(cnt!=n)
				k--;
			if(k>=(1LL<<cnt)){
				puts("-1");
				continue;
			}ans=0;
			for(int j=1;j<=cnt;j++)
				if((k>>cnt-j)&1)
					ans^=a[j];
			printf("%lld\n",ans);
		}
	}
	return 0;
}

  


By NeighThorn

HDU 3949: XOR

标签:algorithm   each   存在   cst   答案   stc   gauss   void   cte   

原文地址:http://www.cnblogs.com/neighthorn/p/6413322.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!