标签:poj 1328 贪心
题目链接:http://poj.org/problem?id=1328
Radar Installation
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 52768 |
|
Accepted: 11867 |
Description
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the
sea can be covered by a radius installation, if the distance between them is at most d.
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write
a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
Figure A Sample Input of Radar Installations
Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing
two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.
The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1
1 2
0 2
0 0
Sample Output
Case 1: 2
Case 2: 1
Source
源代码:
#include <iostream>
#include <cmath>
#include <string.h>
#include <algorithm>
#include <cstdio>
#include <vector>
#include <utility>
using namespace std;
const int maxn = 1000 + 5;
int main()
{
int n, k = 1;
double d;
while (scanf("%d%lf", &n, &d) && (n != 0 || d != 0)) {
vector<pair<double, double> > st;
bool vis[maxn];
memset(vis, false, sizeof(vis));
double x, y, l, r;
bool flag = false;
for (int i = 0; i < n; ++i) {
scanf("%lf%lf", &x, &y);
if (y > d)
flag = true;
if (!flag) {
l = x - sqrt(d * d - y * y);
r = x + sqrt(d * d - y * y);
st.push_back(make_pair(r, l));
}
}
if (flag) {
printf("Case %d: -1\n", k++);
continue;
}
int count = 0;
sort(st.begin(), st.end());
memset(vis, false, sizeof(vis));
for (int i = 0; i < st.size(); ++i) {
if (vis[i])
continue;
++count;
r = st[i].first;
vis[i] = true;
for (int j = i + 1; j < st.size(); ++j)
if (st[j].second <= r)
vis[j] = true;
}
printf("Case %d: %d\n", k++, count);
}
}
对于每一个岛屿,在x轴上都有一个雷达可覆盖其的区间,求最少的雷达,使所有岛屿对应的区间上至少有一个雷达。
将这些区间按照右端点从小到大排序。选择在右端点建设雷达,进行刷选去除。比如,第一个区间为[l, r],则剩下区间中左端点小于r的都去掉。
如此类推……
Poj 1328 Radar Installation 贪心,布布扣,bubuko.com
Poj 1328 Radar Installation 贪心
标签:poj 1328 贪心
原文地址:http://blog.csdn.net/u010826976/article/details/38709251