码迷,mamicode.com
首页 > 其他好文 > 详细

[并查集] More is Better

时间:2017-02-23 15:18:58      阅读:211      评论:0      收藏:0      [点我收藏+]

标签:color   pac   max   hold   after   nbsp   equals   style   题目   

题目描述

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang‘s selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

输入

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

输出

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

样例输入

3 1 3 1 5 2 5 4 3 2 3 4 1 6 2 6

样例输出

4 5
 
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;

int f[10000001];
int num[10000001];

int findFather(int x)
{
    int a=x;
    while(x!=f[x])
    {
        x=f[x];
    }
    while(a!=f[a])
    {
        int z=a;
        a=f[a];
        f[z]=x;
    }
    return x;
}
int ans=1;
void unionf(int a,int b)
{
    int fa=findFather(a);
    int fb=findFather(b);
    if(fa!=fb)
    {
        f[fa]=fb;
        num[fb]=num[fa]+num[fb];
        if(num[fb]>ans)
        {
            ans=num[fb];
        }
    }
}

void init()
{
    for(int i=0;i<10000001;i++)
    {
        f[i]=i;
        num[i]=1;
    }
}

int main()
{
    int n;
    while(cin>>n)
    {
        init();
        int a,b;
        ans=1;
        for(int i=0;i<n;i++)
        {
            cin>>a>>b;
            unionf(a,b);
            //cout<<"ans:"<<ans<<endl;
        }
        cout<<ans<<endl;
    }
    return 0;
}

 

 

[并查集] More is Better

标签:color   pac   max   hold   after   nbsp   equals   style   题目   

原文地址:http://www.cnblogs.com/xiongmao-cpp/p/6433398.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!