码迷,mamicode.com
首页 > 其他好文 > 详细

UVA - 1393 Highways

时间:2014-08-20 22:45:43      阅读:425      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   os   io   for   ar   

Description

bubuko.com,布布扣

Hackerland is a happy democratic country with m×n cities, arranged in a rectangular m by n grid and connected by m roads in the east-west direction and n roads in the north-south direction. By public demand, this orthogonal road system is to be supplemented by a system of highways in sucha way that there will be a direct connection between any pair of cities. Each highway is a straight line going through two or more cities. If two cities lie on the same highway, then they are directly connected.If two cities are in the same row or column, then they are already connected by the existing orthogonal road system (each east-west road connects all the m cities in that row and each north-south road connects all the n cities in that column), thus no new highway is needed to connect them. Your task is to count the number of highway that has to be built (a highway that goes through several cities on a straight line is counted as a single highway).

bubuko.com,布布扣

Input 

The input contains several blocks of test cases. Each test case consists of a single line containing two integers 1bubuko.com,布布扣n , mbubuko.com,布布扣300 , specifying the number of cities. The input is terminated by a test case with n = m = 0 .

Output 

For each test case, output one line containing a single integer, the number of highways that must be built.

Sample Input 

2 4
3 3
0 0

Sample Output 

12
14
题意:有一个n行m列的点阵,问一共有多少条非水平非竖直的直线至少穿过其中的两个点。
思路:这题分两步,首先计算出从点[1, 1]到[n, m]格子组成的边界的连线,然后这是需要容斥去重的,这个有新的数能加的可能是当维度i和j是互质的时候就会多一个,
然后就是递推n*m的格子的总个数,也要容斥去重,这个就是减去减半的数,这个是因为会重线,最后是对称,从左上到右下,和从坐下到右上
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
typedef long long ll;
using namespace std;
const int maxn = 310;

int n, m;
ll dp[maxn][maxn], ans[maxn][maxn];

int gcd(int a, int b) {
	return b==0?a:gcd(b, a%b);
}

void init() {
	memset(dp, 0, sizeof(dp));	
	memset(ans, 0, sizeof(ans));

	for (int i = 1; i <= 300; i++)
		for (int j = 1; j <= 300; j++)
			dp[i][j] = dp[i-1][j] + dp[i][j-1] - dp[i-1][j-1] + (gcd(i, j) == 1);

	for (int i = 1; i <= 300; i++)
		for (int j = 1; j <= 300; j++)
			ans[i][j] = ans[i-1][j] + ans[i][j-1] - ans[i-1][j-1] + dp[i][j] - dp[i>>1][j>>1];
}

int main() {
	init();
	while (scanf("%d%d", &n, &m) != EOF && n+m) {
		printf("%lld\n", ans[n-1][m-1] * 2);	
	}
	return 0;
}

 

UVA - 1393 Highways,布布扣,bubuko.com

UVA - 1393 Highways

标签:des   style   http   color   os   io   for   ar   

原文地址:http://blog.csdn.net/u011345136/article/details/38712447

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!