码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2406 Power Strings

时间:2017-03-01 16:53:27      阅读:199      评论:0      收藏:0      [点我收藏+]

标签:nbsp   contain   integer   ble   ges   concat   i++   16px   循环   

Power Strings
Time Limit: 3000MS   Memory Limit: 65536K
     

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.
求最短循环节的出现次数
求最短循环节长度的方法:
a=len-next[len]
若len%a==0 ,最短循环节长度为a
否则,没有循环节
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int n;
char s[1000001];
int f[1000010];
void getnext()
{
    for(int i=1;i<n;i++)
    {
        int j=f[i];
        while(j&&s[i]!=s[j]) j=f[j];
        f[i+1]= s[i]==s[j] ? j+1:0;
    }
}
int main()
{
    while(cin>>s)
    {
        if(s[0]==.) break;
        n=strlen(s);
        getnext();
        int ans=n-f[n];
        if(n%ans) printf("1\n");
        else printf("%d\n",n/ans);
    }
    
}

 

poj 2406 Power Strings

标签:nbsp   contain   integer   ble   ges   concat   i++   16px   循环   

原文地址:http://www.cnblogs.com/TheRoadToTheGold/p/6484712.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!