码迷,mamicode.com
首页 > 其他好文 > 详细

uva 755

时间:2014-08-21 15:22:24      阅读:237      评论:0      收藏:0      [点我收藏+]

标签:style   color   os   io   for   ar   art   cti   

题目

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino‘s by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens‘‘ number 3-10-10-10.


The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows:


A, B, and C map to 2

D, E, and F map to 3

G, H, and I map to 4

J, K, and L map to 5

M, N, and O map to 6

P, R, and S map to 7

T, U, and V map to 8

W, X, and Y map to 9


There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010.


Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.)


Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.

Input 

The first line of the input contains the number of datasets in the input. A blank line follows. The first line of each dataset specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters. There‘s a blank line between datasets.

Output 

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line:

No duplicates.

Print a blank line between datasets.

Sample Input 

1

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output 

310-1010 2
487-3279 4
888-4567 3

思路及说明

    基础题,直接查表解决,parseNum中应该还能压缩时间。

代码

#include <iostream>
#include <cstring>
#include <string>
#include <cstring>
#include <fstream>
#include <sstream>
#include <vector>
#include <cstdlib>
#include <cstdio>
#include <map>
using namespace std;


#ifdef DEBUG
ifstream in;
ofstream out;
#endif

#ifdef DEBUG
#define inpath      "./in.txt"
#define outpath     "./out.txt"
#define CIN     in
#define COUT    out
#else
#define CIN     cin
#define COUT    cout
#endif


/*
A,B,andC mapto   2
D,E,and F mapto   3
G,H,and I mapto   4
J,K,and L mapto   5
M,N,and O mapto  6
P,R,and S mapto   7
T,U,and V mapto   8
W,X,and Y mapto   9
*/

struct keyTable{
    keyTable(){
            memset(table, 0, sizeof(char) * 256);
            table[‘A‘] = ‘2‘;
             table[‘B‘] = ‘2‘;
              table[‘C‘] = ‘2‘;
               table[‘D‘] = ‘3‘;
                table[‘E‘] = ‘3‘;
                 table[‘F‘] = ‘3‘;
                  table[‘G‘] = ‘4‘;
                   table[‘H‘] = ‘4‘;
                    table[‘I‘] = ‘4‘;
                     table[‘J‘] = ‘5‘;
                      table[‘K‘] = ‘5‘;
                       table[‘L‘] = ‘5‘;
                       table[‘M‘] = ‘6‘;
                       table[‘N‘] = ‘6‘;
                       table[‘O‘] = ‘6‘;
                       table[‘P‘] = ‘7‘;
                       table[‘R‘] = ‘7‘;
                       table[‘S‘] = ‘7‘;
                       table[‘T‘] = ‘8‘;
                       table[‘U‘] = ‘8‘;
                       table[‘V‘] = ‘8‘;
                       table[‘W‘] = ‘9‘;
                       table[‘X‘] = ‘9‘;
                       table[‘Y‘] = ‘9‘;
    }
    char convert(const char k){
            char ret = table[k];
            if( 0 == ret )
                    return k;
            else
                    return ret;
    }
    int table[256];
};

string parseNum(string vnum,struct keyTable &kt){
                string  num;
                int idx = 1;
                for(string::iterator iter= vnum.begin(); iter != vnum.end(); iter++){
                        if( *iter == (char)‘-‘)
                               ;
                        else{
                                num += kt.convert(*iter);
                                if(3 == idx)
                                    num += ‘-‘;
                                  idx++;
                        }

                }
#ifdef DEBUG
            cout << vnum<< " -> " << num << endl;
#endif // DEBUG
            return num;
}

int main()
{
#ifdef DEBUG
    in.open(inpath,     ios::in);
    out.open(outpath,   ios::out);
    if(in.fail()){
            cout << "input init fail " << "\n";
            return -1;
    }
    if(out.fail()){
             cout << "output init fail " << "\n";
            return -1;
    }
#endif
    struct keyTable kt;
    int cases;
    int numTot;
    string str;
    map<string, int> ansTable;
     CIN >> cases;
     while(cases--){
        ansTable.clear();
        CIN >> numTot;
        for(int numCurr = 1; numCurr <= numTot; numCurr++){
                CIN >> str;
                ansTable[parseNum(str, kt)]++;
        }
        int  flag = 0;
        for(map<string, int>::iterator iter = ansTable.begin(); iter != ansTable.end(); iter++){
                    if(iter->second > 1){
                        COUT << iter->first << " " << iter->second << endl;
                        flag = 1;
                    }
        }
        if(0 == flag){
                COUT<<"No duplicates."<<endl;
        }
        if(0 != cases)
                COUT << endl;
     }
return 0;
}

uva 755,布布扣,bubuko.com

uva 755

标签:style   color   os   io   for   ar   art   cti   

原文地址:http://my.oschina.net/u/572632/blog/305100

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!