码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2769 Reduced ID Numbers

时间:2014-08-21 17:24:04      阅读:166      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   os   io   for   ar   2014   

思路: 枚举

Reduced ID Numbers
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 8847 Accepted: 3552
Description

T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with MaxSIN = 106-1. T. Chur finds this range of SINs too large for identification within her groups. For each group, she wants to find the smallest positive integer m, such that within the group all SINs reduced modulo m are unique.
Input

On the first line of the input is a single positive integer N, telling the number of test cases (groups) to follow. Each case starts with one line containing the integer G (1 ≤ G ≤ 300): the number of students in the group. The following G lines each contain one SIN. The SINs within a group are distinct, though not necessarily sorted.
Output

For each test case, output one line containing the smallest modulus m, such that all SINs reduced modulo m are distinct.
Sample Input

2
1
124866
3
124866
111111
987651
Sample Output

1
8
Source

Northwestern Europe 2005

<span style="color:#3333ff;">/*********************************************
        author    : Grant Yuan
        time      : 2014/8/21 14:45
        algorithm : Basic Math
        source    : POJ 2769
**********************************************/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#define MAX 100000

using namespace std;
bool flag[MAX];
int a[307];
int b[307];

void init(int n)
{
    for(int i=0;i<n;i++)
    {
        flag[b[i]]=false;
        b[i]=0;
    }
}

int main()
{
    int t,ans;
    scanf("%d",&t);
    while(t--){
        int n;
        scanf("%d",&n);
        memset(flag,0,sizeof(flag));
        memset(b,0,sizeof(b));
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        for(int i=n;;i++)
        {
            init(n);
            bool f=true;
           for(int j=0;j<n;j++)
           {
              int m=a[j]%i;
              if(flag[m]) {f=false;break;}
              else {flag[m]=true; b[j]=m;}
           }
           if(f) {ans=i;break;}
        }
        printf("%d\n",ans);
    }
    return 0;
}
</span>


POJ 2769 Reduced ID Numbers,布布扣,bubuko.com

POJ 2769 Reduced ID Numbers

标签:des   style   color   os   io   for   ar   2014   

原文地址:http://blog.csdn.net/yuanchang_best/article/details/38729761

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!