码迷,mamicode.com
首页 > 其他好文 > 详细

HDU3257 Hello World!

时间:2014-08-21 19:13:24      阅读:278      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   java   os   io   strong   

Hello World!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 465    Accepted Submission(s): 172


Problem Description
Your task is to print ... er ... "Hello World" ... in a fantastic way -- using a beautiful font.

I‘ve sent you a nice font for you to use, but I‘m too busy to tell you how. Can you help yourself?
 

Input
The first line contains a single integer T (T <= 20), the number of test cases.
Each case begins with an integer C (1 <= C <= 80) in a single line, then each of the following C lines contains five two-digit numbers in hex (letters will be in uppercase). Don‘t ask me what they mean, I‘m too busy...
 

Output
For each test case, print the case number in the first line, then followed by a blank line.
After that, print all T characters. Use a single blank column of spaces between two consecutive characters. Each line should have exactly 6C-1 character (again, don‘t ask me why).
Don‘t forget to print another blank line after the output of each test case.
 

Sample Input
2 11 7F 08 08 08 7F 38 54 54 54 18 00 41 7F 40 00 00 41 7F 40 00 38 44 44 44 38 00 00 00 00 00 3F 40 38 40 3F 38 44 44 44 38 7C 08 04 04 08 00 41 7F 40 00 38 44 44 48 7F 5 14 08 3E 08 14 04 02 01 02 04 40 40 40 40 40 04 02 01 02 04 14 08 3E 08 14
 

Sample Output
Case 1: # # ## ## # # ## # # # # # # # # # # # ### # # ### # # ### # ## # ## # ##### # # # # # # # # # # # ## # # # ## # # ##### # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # ### ### ### ### # # ### # ### #### Case 2: # # # # # # # # # # # # # # # # # # ### ### # # # # # # # # #####
 

Source

题意:前面基本上都是废话,主要是让你自己看输入输出找规律。

题解:坑人的地方是这题输出的时候事实上是7行,而不是8行!!!因此PE了N次!


#include <stdio.h>
#define maxn 482

char map[8][maxn];
bool isPrint[8];

void getIsPrint(int n)
{
    for(int i = 0; i < 7; ++i){
        isPrint[i] = n & 1;
        n >>= 1;
    }
}

int main()
{
    //freopen("stdout.txt", "w", stdout);
    int t, n, arr[5], i, j, id, k, cas = 1;
    scanf("%d", &t);
    while(t--){
        scanf("%d", &n);
        for(i = id = 0; i < n; ++i){
            for(j = 0; j < 5; ++j, ++id){
                scanf("%X", arr + j);
                getIsPrint(arr[j]);
                for(k = 0; k < 7; ++k)
                    if(isPrint[k]) map[k][id] = '#';
                    else map[k][id] = ' ';
            }
            if(i != n - 1){
                for(k = 0; k < 7; ++k)
                    map[k][id] = ' ';
                ++id;
            }
        }
        printf("Case %d:\n\n", cas++);
        for(k = 0; k < 7; ++k){
            map[k][id] = '\0';
            printf("%s\n", map[k]);
        }
        printf("\n");
    }
    return 0;
}


HDU3257 Hello World!,布布扣,bubuko.com

HDU3257 Hello World!

标签:des   style   http   color   java   os   io   strong   

原文地址:http://www.cnblogs.com/mfrbuaa/p/3927773.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!