码迷,mamicode.com
首页 > 其他好文 > 详细

[SPOJ7258]Lexicographical Substring Search

时间:2017-03-13 20:11:29      阅读:201      评论:0      收藏:0      [点我收藏+]

标签:main   getchar   str   ide   nsis   exce   csharp   putchar   etc   

[SPOJ7258]Lexicographical Substring Search

试题描述

Little Daniel loves to play with strings! He always finds different ways to have fun with strings! Knowing that, his friend Kinan decided to test his skills so he gave him a string S and asked him Q questions of the form:


If all distinct substrings of string S were sorted lexicographically, which one will be the K-th smallest?


After knowing the huge number of questions Kinan will ask, Daniel figured out that he can‘t do this alone. Daniel, of course, knows your exceptional programming skills, so he asked you to write him a program which given S will answer Kinan‘s questions.

Example:


S = "aaa" (without quotes)
substrings of S are "a" , "a" , "a" , "aa" , "aa" , "aaa". The sorted list of substrings will be:
"a", "aa", "aaa".

输入

In the first line there is Kinan‘s string S (with length no more than 90000 characters). It contains only small letters of English alphabet. The second line contains a single integer Q (Q <= 500) , the number of questions Daniel will be asked. In the next Q lines a single integer K is given (0 < K < 2^31).

输出

Output consists of Q lines, the i-th contains a string which is the answer to the i-th asked question.

输入示例

aaa
2
2
3

输出示例

aa
aaa

题解

这题其实就是这道题的一个子问题。

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cctype>
#include <algorithm>
using namespace std;

int read() {
	int x = 0, f = 1; char c = getchar();
	while(!isdigit(c)){ if(c == ‘-‘) f = -1; c = getchar(); }
	while(isdigit(c)){ x = x * 10 + c - ‘0‘; c = getchar(); }
	return x * f;
}

#define maxn 90010

char S[maxn];
int n, rank[maxn], height[maxn], sa[maxn], Ws[maxn];

bool cmp(int* a, int p1, int p2, int l) {
	if(p1 + l > n && p2 + l > n) return a[p1] == a[p2];
	if(p1 + l > n || p2 + l > n) return 0;
	return a[p1] == a[p2] && a[p1+l] == a[p2+l];
}
void ssort() {
	int *x = rank, *y = height;
	int m = 0;
	for(int i = 1; i <= n; i++) Ws[x[i] = S[i]]++, m = max(m, x[i]);
	for(int i = 1; i <= m; i++) Ws[i] += Ws[i-1];
	for(int i = n; i; i--) sa[Ws[x[i]]--] = i;
	for(int j = 1, pos = 0; pos < n; j <<= 1, m = pos) {
		pos = 0;
		for(int i = n - j + 1; i <= n; i++) y[++pos] = i;
		for(int i = 1; i <= n; i++) if(sa[i] > j) y[++pos] = sa[i] - j;
		for(int i = 1; i <= m; i++) Ws[i] = 0;
		for(int i = 1; i <= n; i++) Ws[x[i]]++;
		for(int i = 1; i <= m; i++) Ws[i] += Ws[i-1];
		for(int i = n; i; i--) sa[Ws[x[y[i]]]--] = y[i];
		swap(x, y); pos = 1; x[sa[1]] = 1;
		for(int i = 2; i <= n; i++) x[sa[i]] = cmp(y, sa[i], sa[i-1], j) ? pos : ++pos;
	}
	return ;
}
void calch() {
	for(int i = 1; i <= n; i++) rank[sa[i]] = i;
	for(int i = 1, j, k = 0; i <= n; height[rank[i++]] = k)
		for(k ? k-- : 0, j = sa[rank[i]-1]; S[j+k] == S[i+k]; k++);
	return ;
}

int en[maxn];

int main() {
	scanf("%s", S + 1);
	n = strlen(S + 1);
	
	ssort();
	calch();
	for(int i = 1; i <= n; i++) en[i] = n - sa[i] + 1 - height[i];
	for(int i = 1; i <= n; i++) en[i] += en[i-1];
	int q = read();
	while(q--) {
		int k = read(), p = lower_bound(en + 1, en + n + 1, k) - en;
		int l = sa[p], r = n - (en[p] - k);
		for(int i = l; i <= r; i++) putchar(S[i]); putchar(‘\n‘);
	}
	
	return 0;
}

 

[SPOJ7258]Lexicographical Substring Search

标签:main   getchar   str   ide   nsis   exce   csharp   putchar   etc   

原文地址:http://www.cnblogs.com/xiao-ju-ruo-xjr/p/6544662.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!