码迷,mamicode.com
首页 > 其他好文 > 详细

Problem A: 平面上的点——Point类 (III)

时间:2017-03-15 20:26:34      阅读:271      评论:0      收藏:0      [点我收藏+]

标签:play   precision   double   stream   封装   show   ons   input   using   

Description

在数学上,平面直角坐标系上的点用X轴和Y轴上的两个坐标值唯一确定。现在我们封装一个“Point类”来实现平面上的点的操作。

根据“append.cc”,完成Point类的构造方法和show()方法,输出各Point对象的构造和析构次序。实现showPoint()函数。

接口描述:
showPoint()函数按输出格式输出Point对象,调用Point::show()方法实现。
Point::show()方法:按输出格式输出Point对象。

Input

输入多行,每行为一组坐标“x,y”,表示点的x坐标和y坐标,x和y的值都在double数据范围内。

Output

输出每个Point对象的构造和析构行为。showPoint()函数用来输出(通过参数传入的)Point对象的值:X坐标在前,Y坐标在后,Y坐标前面多输出一个空格。每个坐标的输出精度为最长16位。输出格式见sample。

C语言的输入输出被禁用。

Sample Input

1,2 3,3 2,1

Sample Output

Point : (0, 0) is created.
Point : (1, 2) is created.
Point : (1, 2) is copied.
Point : (1, 2)
Point : (1, 2) is erased.
Point : (1, 2) is erased.
Point : (3, 3) is created.
Point : (3, 3) is copied.
Point : (3, 3)
Point : (3, 3) is erased.
Point : (3, 3) is erased.
Point : (2, 1) is created.
Point : (2, 1) is copied.
Point : (2, 1)
Point : (2, 1) is erased.
Point : (2, 1) is erased.
Point : (0, 0) is copied.
Point : (1, 1) is created.
Point : (0, 0) is copied.
Point : (1, 1) is copied.
Point : (0, 0) is copied.
Point : (0, 0)
Point : (1, 1)
Point : (0, 0)
Point : (0, 0) is erased.
Point : (1, 1) is erased.
Point : (0, 0) is erased.
Point : (1, 1) is erased.
Point : (0, 0) is erased.
Point : (0, 0) is erased.

HINT

思考构造函数、拷贝构造函数、析构函数的调用时机。

Append Code

#include<iostream>
#include<iomanip>
using namespace std;
class Point
{
private:
    double x,y;
public:
    Point(double a):x(a),y(a){cout<<setprecision(16)<<"Point : ("<<x<<", "<<y<<") is created.\n";}
    Point():x(0),y(0){cout<<setprecision(16)<<"Point : ("<<x<<", "<<y<<") is created.\n";}
    Point(double a,double b):x(a),y(b){cout<<setprecision(16)<<"Point : ("<<x<<", "<<y<<") is created.\n";}
    Point(const Point &q):x(q.x),y(q.y){cout<<setprecision(16)<<"Point : ("<<x<<", "<<y<<") is copied.\n";}
    ~Point(){cout<<setprecision(16)<<"Point : ("<<x<<", "<<y<<") is erased.\n";}
    void show(){cout<<setprecision(16)<<"Point : ("<<x<<", "<<y<<")\n";}
};
void showPoint(Point p){p.show();}
void showPoint(Point q,Point w,Point e){q.show();w.show();e.show();}
int main()
{
    char c;
    double a, b;
    Point q;
    while(std::cin>>a>>c>>b)
    {
        Point p(a, b);
        showPoint(p);
    }
    Point q1(q), q2(1);
    showPoint(q1, q2, q);
}
int main()
{
    cout<<"Static member test output :"<<endl;
    Time::displayNumber();
    Time t;
    t.displayNumber();
    Time tt(t);
    tt.displayNumber();
    Time ttt(1, 2, 3);
    ttt.displayNumber();
    Time tttt(ttt.getTime());
    tttt.displayNumber();
    int non_cases = Time::getNumber();

    cout<<"\nTest data output :"<<endl;
    int hour, minute, second;
    while(cin>>hour>>minute>>second)
    {
        Time t;
        t.setTime(hour, minute, second).showTime();
    }
    cout<<t.getNumber() - non_cases<<endl;
}

Problem A: 平面上的点——Point类 (III)

标签:play   precision   double   stream   封装   show   ons   input   using   

原文地址:http://www.cnblogs.com/TogetherLaugh/p/6555999.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!