码迷,mamicode.com
首页 > 其他好文 > 详细

POJ1015 DP

时间:2017-03-17 23:16:53      阅读:232      评论:0      收藏:0      [点我收藏+]

标签:style   ret   line   ott   integer   name   minimal   count   ade   

Jury Compromise
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 28927   Accepted: 7676   Special Judge

Description

In Frobnia, a far-away country, the verdicts in court trials are determined by a jury consisting of members of the general public. Every time a trial is set to begin, a jury has to be selected, which is done as follows. First, several people are drawn randomly from the public. For each person in this pool, defence and prosecution assign a grade from 0 to 20 indicating their preference for this person. 0 means total dislike, 20 on the other hand means that this person is considered ideally suited for the jury. 
Based on the grades of the two parties, the judge selects the jury. In order to ensure a fair trial, the tendencies of the jury to favour either defence or prosecution should be as balanced as possible. The jury therefore has to be chosen in a way that is satisfactory to both parties. 
We will now make this more precise: given a pool of n potential jurors and two values di (the defence‘s value) and pi (the prosecution‘s value) for each potential juror i, you are to select a jury of m persons. If J is a subset of {1,..., n} with m elements, then D(J ) = sum(dk) k belong to J 
and P(J) = sum(pk) k belong to J are the total values of this jury for defence and prosecution. 
For an optimal jury J , the value |D(J) - P(J)| must be minimal. If there are several jurys with minimal |D(J) - P(J)|, one which maximizes D(J) + P(J) should be selected since the jury should be as ideal as possible for both parties. 
You are to write a program that implements this jury selection process and chooses an optimal jury given a set of candidates.

Input

The input file contains several jury selection rounds. Each round starts with a line containing two integers n and m. n is the number of candidates and m the number of jury members. 
These values will satisfy 1<=n<=200, 1<=m<=20 and of course m<=n. The following n lines contain the two integers pi and di for i = 1,...,n. A blank line separates each round from the next. 
The file ends with a round that has n = m = 0.

Output

For each round output a line containing the number of the jury selection round (‘Jury #1‘, ‘Jury #2‘, etc.). 
On the next line print the values D(J ) and P (J ) of your jury as shown below and on another line print the numbers of the m chosen candidates in ascending order. Output a blank before each individual candidate number. 
Output an empty line after each test case.

Sample Input

4 2 
1 2 
2 3 
4 1 
6 2 
0 0 

Sample Output

Jury #1 
Best jury has value 6 for prosecution and value 4 for defence: 
 2 3 

Hint

If your solution is based on an inefficient algorithm, it may not execute in the allotted time.

Source

题意:
n个人,每人有两个属性,支持度d和反对度p,从n个人中按照要求选出m个人。要求:m个人的p和与d和的差最小的情况下p+d的和最大,输出d的和,p的和他们分别是谁。
代码:
/*
为叙述问题方便,现将任一选择方案中,辩方总分和控方总分之差简称为“辩控差”,
辩方总分和控方总分之和称为“辩控和”。第i 个候选人的辩方总分和控方总分之差
记为V(i),辩方总分和控方总分之和记为S(i)。现用dp(j, k)表示,取j 个候选人,
使其辩控差为k 的所有方案中,辩控和最大的那个方案(该方案称为“方案dp(j, k)”)
的辩控和。并且,我们还规定,如果没法选j 个人,使其辩控差为k,那么dp(j, k)的
值就为-1,也称方案dp(j, k)不可行。本题是要求选出m 个人,那么,如果对k 的
所有可能的取值,求出了所有的dp(m, k) (-20×m≤ k ≤ 20×m),那么陪审团方案自然
就很容易找到了。
    问题的关键是建立递推关系。需要从哪些已知条件出发,才能求出dp(j, k)呢?
显然,方案dp(j, k)是由某个可行的方案dp(j-1, x)( -20×m ≤ x ≤ 20×m)演化而来的。
可行方案dp(j-1, x)能演化成方案dp(j, k)的必要条件是:存在某个候选人i,i 
在方案dp(j-1, x)中没有被选上,且x+V(i) = k。在所有满足该必要条件的dp(j-1, x)中
,选出 dp(j-1, x) + S(i) 的值最大的那个,那么方案dp(j-1, x)再加上候选人i,就
演变成了方案 dp(j, k)。这中间需要将一个方案都选了哪些人都记录下来。不妨将方案
dp(j, k)中最后选的那个候选人的编号,记在二维数组的元素path[j][k]中。那么方案
dp(j, k)的倒数第二个人选的编号,就是path[j-1][k-V[path[j][k]]]。假定最后算出
了解方案的辩控差是k,那么从path[m][k]出发,就能顺藤摸瓜一步步回溯求出所有被选中的候选人。
初始条件,只能确定dp(0, 0) = 0,其他均为-1。由此出发,一步步自底向上递推,就
能求出所有的可行方案dp(m, k)( -20×m ≤ k ≤ 20×m)。实际解题的时候,会用一个二维
数组dp 来存放dp(j, k)的值。而且,由于题目中辩控差的值k 可以为负数,而程序中数
租下标不能为负数,所以,在程序中不妨将辩控差的值都加上修正值fix=400,以免下标
为负数导致出错。
为什么fix=400?这是很显然的,m上限为20人,当20人的d均为0,p均为20时,会出现辨
控差为-400。修正后回避下标负数问题,区间整体平移,从[-400,400]映射到[0,800]。
此时初始条件修正为dp(0, fix) = 0,其他均为-1。
DP后,从第m行的dp(m, fix)开始往两边搜索最小|D-P| 即可,第一个不为dp[m][k]!=-1的
位置k就是最小|D-P|的所在。
最后就是求m个人的D和P,由于D+P = dp(m, |D-P| ) ,|D-P|已知。
那么D= (D+P + |D-P| )/2  ,  P=(D+P-|D-P| ) / 2
计算D和P时注意修正值fix
*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int d[300],p[300],c[300],h[300],f[30][900],path[30][900];
int main()
{
    int n,m,cas=0;
    while(scanf("%d%d",&n,&m)&&(n+m)){
        for(int i=1;i<=n;i++){
            scanf("%d%d",&d[i],&p[i]);
            c[i]=d[i]-p[i];
            h[i]=d[i]+p[i];
        }
        memset(f,-1,sizeof(f));
        memset(path,0,sizeof(path));
        int M=m*20;
        f[0][M]=0;
        for(int i=0;i<m;i++){
            for(int j=0;j<=M*2;j++){
                if(f[i][j]==-1) continue;
                for(int k=1;k<=n;k++){
                    if(f[i][j]+h[k]>f[i+1][j+c[k]]){
                        int t1=i,t2=j;
                        while(t1>0&&path[t1][t2]!=k){
                            t2-=c[path[t1][t2]];
                            t1--;
                        }
                        if(t1==0){
                            f[i+1][j+c[k]]=f[i][j]+h[k];
                            path[i+1][j+c[k]]=k;
                        }
                    }
                }
            }
        }
        int i;
        for(i=0;;i++){
            if(f[m][M+i]!=-1) break;
            if(f[m][M-i]!=-1) break;
        }
        int ans1,ans2,t1=m,t2;
        if(f[m][M+i]>f[m][M-i]){
            ans1=(i+f[m][M+i])/2;
            ans2=f[m][M+i]-ans1;
            t2=M+i;
        }
        else{
            ans1=(-i+f[m][M-i])/2;
            ans2=f[m][M-i]-ans1;
            t2=M-i;
        }
        printf("Jury #%d\n",++cas);
        printf("Best jury has value %d for prosecution and value %d for defence:\n",ans1,ans2);
        int tmp[30],cnt=0;
        while(t1){
            tmp[cnt++]=path[t1][t2];
            t2-=c[path[t1][t2]];
            t1--;
        }
        sort(tmp,tmp+cnt);
        for(int j=0;j<cnt;j++) printf(" %d",tmp[j]);
        printf("\n\n");
    }
    return 0;
}

 

POJ1015 DP

标签:style   ret   line   ott   integer   name   minimal   count   ade   

原文地址:http://www.cnblogs.com/--ZHIYUAN/p/6568970.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!