码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1328 Radar lnstallation 2

时间:2017-03-18 00:50:18      阅读:152      评论:0      收藏:0      [点我收藏+]

标签:note   this   osi   poi   char   bre   get   tin   system   

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations


Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1







贪心:注意重点
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<cmath>
using namespace std;
int f[1010];
struct aa
{
    double x,y;
}a[1010];
int cmp(aa q,aa w)
{
    return q.x<w.x;
}
int main()
{
    int k,n,m,cnt,ka=0;
    while(cin>>n>>m)
    {   if(n==0&&m==0)break;
        ka++;
        int flat=1;
        k=0;
        double x,y,c,mm=(double)m*m;
        for(int i=1;i<=n;i++)
        {
          cin>>x>>y;
          if(m>=y)
          {c=sqrt(mm-y*y);
           a[++k].x=x-c;
           a[k].y=x+c;
          }
          else
         {
             flat=0;
          }

        }
        getchar();
        if(flat)
        {sort(a+1,a+k+1,cmp);
        double now = a[1].y;
         cnt = 1;
        for(int i=2;i<=k;i++)
        {
          if(a[i].y<now)
            now=a[i].y;
          else if(a[i].x>now)
          {
              cnt++;
              now=a[i].y;
          }
        }
        }
        else
        cnt=-1;
        cout<<"Case "<<ka<<": "<<cnt<<endl;
    }
    return 0;
}

POJ 1328 Radar lnstallation 2

标签:note   this   osi   poi   char   bre   get   tin   system   

原文地址:http://www.cnblogs.com/552059511wz/p/6569155.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!