码迷,mamicode.com
首页 > 其他好文 > 详细

hdu3549 Flow Problem(裸最大流)

时间:2014-08-22 00:20:05      阅读:244      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   os   io   strong   

 

                                              Flow Problem
Time Limit:5000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
 

Input

The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
 

Output

For each test cases, you should output the maximum flow from source 1 to sink N.
 

Sample Input

2 3 2 1 2 1 2 3 1 3 3 1 2 1 2 3 1 1 3 1
 

Sample Output

Case 1: 1

Case 2: 2


题目比较简单,入门级最大流问题。

bubuko.com,布布扣
#include<cstdio>
#include<algorithm>
#include<queue>
#include<string.h>
#define MAXN 21
#define INF 1<<28

using namespace std;

int cap[MAXN][MAXN], pre[MAXN], vis[MAXN], maxflow[MAXN];
int Maxflow;
int n, m, i, j;

void init()
{
    int x, y, z;
    memset(cap, 0sizeof(cap));
    memset(pre, 0sizeof(pre));

    scanf("%d%d", &n, &m);
    for(i=1; i<=m; i++)
    {
        scanf("%d%d%d", &x, &y, &z);
        cap[x][y] += z;//重边
    }
}

int min(int a, int b)
{
    return a>b?b:a;
}

int main()
{
    int T, u, k=1;
    scanf("%d", &T);
    while(T--)
    {

        init();
        queue<int>q;
        Maxflow = 0;

        while(1)
       {
        memset(maxflow, 0sizeof(maxflow));
        memset(vis, 0sizeof(vis));
        maxflow[1] = INF;


        q.push(1);
        while(!q.empty())
        {
             u = q.front();
             q.pop();
             for(int v=1; v<=n; v++)
             {
                 if(!vis[v] && cap[u][v]>0)
                    {
                        vis[v] = 1;
                        pre[v] = u;
                        q.push(v);
                        maxflow[v] = maxflow[u]<cap[u][v]?maxflow[u]:cap[u][v];
                    }
             }
        }
        if(maxflow[n]==0break;

        for(int i=n; i!=1; i=pre[i])
        {
            cap[pre[i]][i]-=maxflow[n];
            cap[i][pre[i]]+=maxflow[n];
        }

       Maxflow += maxflow[n];
    }
      printf("Case %d: %d\n", k++, Maxflow);
    }
     return 0;
}
View Code

hdu3549 Flow Problem(裸最大流),布布扣,bubuko.com

hdu3549 Flow Problem(裸最大流)

标签:des   style   blog   http   color   os   io   strong   

原文地址:http://www.cnblogs.com/6bing/p/3928329.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!